Collection edit-mode not working properly

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: evyatar, Assigned: evyatar)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1. Shake animation doesn't work
2. Clicking the Remove button doesn't work, instead it triggers a normal click action

STR:
1. Open a collection
2. Long-tap one of the pinned apps (apps above the line)
3. Tap the Remove button

Result:
The icons don't display the same animation as the homescreen grid.
Tapping the Remove button doesn't remove the app. instead it launches it.

Expected:
The icons should pulsate like the homescreen icons in edit mode.
Tapping the Remove button should remove the app.
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Created attachment 812626 [details]
Patch - redirect to github PR
Attachment #812626 - Flags: review?(crdlc)
Attachment #812626 - Flags: review?(amirn)
Comment on attachment 812626 [details]
Patch - redirect to github PR

I added dragdrop.css when we are in edit mode so I broke it thought :)
Attachment #812626 - Flags: review?(crdlc) → review+
Please add dependencies to bug
yeah it's the lazy load :) do you know its bug ID?
anyway the lazy-load is already in master, so there's no real dependency - this could (and should) be merged directly to master.
Depends on: 916690

Updated

5 years ago
Attachment #812626 - Flags: review?(amirn) → review+
Added dependency to bug 916690
landed on master
372042a09b17a61a0b428b20ccbe98654c6a78f1

https://github.com/mozilla-b2g/gaia/commit/372042a09b17a61a0b428b20ccbe98654c6a78f1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 911945
blocking-b2g: --- → koi?
removing koi? since e.me 1.2 features are delayed for future version
blocking-b2g: koi? → ---
You need to log in before you can comment on or make changes to this bug.