[Flatfish][Music] Cannot retrieve music info correctly

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: atsai, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

(Whiteboard: [flatfishRun1, Flatfish only])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 812994 [details]
music.png

Cannot retrieve music info correctly on flatfish

[Environment]
DuT:      Flatfish
Gaia:     def8e152db6a317162c03a316f68c409f3af3979
Gecko:    6ae6fea8d39011d1f9abfdb334ca800bfd5b5227
Gecko after patch: 9eedb6201641498fee3fcc654100058ca404ac40
(Reporter)

Updated

4 years ago
Blocks: 903304
QA Contact: atsai
Whiteboard: flatfishRun1

Updated

4 years ago
blocking-b2g: --- → koi+
Whiteboard: flatfishRun1 → [flatfishRun1, Flatfish only]
(In reply to Al Tsai [:atsai] from comment #0)
> Created attachment 812994 [details]
> music.png
> 
> Cannot retrieve music info correctly on flatfish
> 
> [Environment]
> DuT:      Flatfish
> Gaia:     def8e152db6a317162c03a316f68c409f3af3979
> Gecko:    6ae6fea8d39011d1f9abfdb334ca800bfd5b5227
> Gecko after patch: 9eedb6201641498fee3fcc654100058ca404ac40

Hi Al Tsai, 

after confirming with Dominic, it seems that when you play *.mp3 music in older gecko, it will throw error "Unplayable music file" when playing.

Can you update your gecko and try again ? :D
Flags: needinfo?(atsai)
See Also: → bug 922972
> Hi Al Tsai, 
> 
> after confirming with Dominic, it seems that when you play *.mp3 music in
> older gecko, it will throw error "Unplayable music file" when playing.
> 
> Can you update your gecko and try again ? :D

Is it possible that flatfish is running on Android 4.2? maybe related to some porting issues?

Comment 3

4 years ago
If the duration shows ---:-- then the audio tag was failed to play. The duration should display correctly when the audio tag plays successfully, so this should not be a gaia issue, probably we need to change the component.

Comment 4

4 years ago
Hi,

As I know that mp3 format is decoded by OMX Codec too, so once GonkNativeWindown for JB 4.2 is not landed the OMX Codec not enabled too. Then mp3 can't be supported.
Per comment 4, the issue is blocked by issue 922510.
Component: Gaia::Music → General
Depends on: 922510
Flags: needinfo?(atsai)

Comment 6

4 years ago
Currently the latest version of flatfish can both play *.mp3 and *.ogg so I believe this bug can be closed. Reopen it if anyone has concern. Thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v1.2: --- → fixed
You need to log in before you can comment on or make changes to this bug.