Closed Bug 923274 Opened 6 years ago Closed 6 years ago

Cannot open activity picker from input=file element on 1.2 most of the time

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, firefox26 wontfix, firefox27 wontfix, firefox28 verified, b2g-v1.2 verified)

VERIFIED FIXED
1.3 Sprint 5 - 11/22
blocking-b2g koi+
Tracking Status
firefox26 --- wontfix
firefox27 --- wontfix
firefox28 --- verified
b2g-v1.2 --- verified

People

(Reporter: jsmith, Assigned: baku)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build: Hamachi 1.2 10/2/2013

STR

1. Go to http://mozilla.github.io/qa-testcase-data/webapi/filemanagement/fileUploadTest.html
2. Select Browser

Expected

The activity picker should appear.

Actual

In almost all cases, the activity picker fails to appear.
Blocks: 920905
blocking-b2g: --- → koi?
Keywords: regression
needinfo on :baku, is there a patch upcoming in https://bugzilla.mozilla.org/show_bug.cgi?id=920905 which will help this issue?
blocking-b2g: koi? → koi+
Flags: needinfo?(amarchesini)
(In reply to bhavana bajaj [:bajaj] from comment #1)
> needinfo on :baku, is there a patch upcoming in
> https://bugzilla.mozilla.org/show_bug.cgi?id=920905 which will help this
> issue?

not really. I'll investigate why this doesn't work.
Flags: needinfo?(amarchesini)
Using the page in comment 0, this works for me when choosing file pickers with the image or video filters. Did we ever support something else?
I'll retest this tomorrow.
Keywords: qawanted
QA Contact: jsmith
(In reply to Fabrice Desré [:fabrice] from comment #3)
> Using the page in comment 0, this works for me when choosing file pickers
> with the image or video filters. Did we ever support something else?

Hmm interesting. So this fails on cases when no filters are included on the input file element. If a filter is included, it works. I just confirmed that behavior as well.
Keywords: qawanted
Jason, so you think it's a regression from 1.1?
(In reply to Fabrice Desré [:fabrice] from comment #6)
> Jason, so you think it's a regression from 1.1?

I think so - I thought we added support for this in 1.1. I recall testing this via my test page originally on 1.1.

I'll add regression window wanted to get more info to get this move forward more.
QA Contact: jsmith
QA Contact: mvaughan
This issue started reproducing on the 6/29/13 1.2 build. The closest build I can find on the pvt build website, that was working before the 6/29 build, is the 6/24 build. 

- Works -
Environmental Variables:
Device: Buri v1.2 MOZ RIL
BuildID: 20130624031223
Gaia: 59c7f4a59157a0bc1c45d705294395f988c509b2
Gecko: 76820c6dff7b
Version: 24.0a1
Firmware Version: 20131104

- Broken -
Environmental Variables:
Device: Buri v1.2 MOZ RIL
BuildID: 20130629031257
Gaia: a8252a4a096431ca7f39b0ce9307957945f77075
Gecko: c5ce065936fa
Version: 25.0a1
Firmware Version: 20131104
(In reply to Andrea Marchesini (:baku) from comment #2)
> (In reply to bhavana bajaj [:bajaj] from comment #1)
> > needinfo on :baku, is there a patch upcoming in
> > https://bugzilla.mozilla.org/show_bug.cgi?id=920905 which will help this
> > issue?
> 
> not really. I'll investigate why this doesn't work.

Thanks, passing this onto you for further investigation then.
Assignee: nobody → amarchesini
Jason,

Can you please confirm if this was a regression issue from 1.1?
Flags: needinfo?(jsmith)
QA Wanted to check what happens on 1.1.
Flags: needinfo?(jsmith)
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #11)
> QA Wanted to check what happens on 1.1.

Big sigh of relief - this works fine on 1.1.
Keywords: qawanted
Andrea,

Do we have an investigation for the same?
Flags: needinfo?(amarchesini)
yes. I'm testing it right now. Soon I'll write a new comment.
Flags: needinfo?(amarchesini)
Attached patch fp.patchSplinter Review
Attachment #8335404 - Flags: review?(fabrice)
Comment on attachment 8335404 [details] [diff] [review]
fp.patch

Review of attachment 8335404 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/activities/tests/unit/test_activityFilters.js
@@ +151,5 @@
>    do_check_true(ActivitiesServiceFilter.match({a: 'FoOBaR'},
>                                                {a: { required: true, pattern: 'foobar', patternFlags: 'i'}}));
> +
> +  // Bug 923274
> +  do_check_true(ActivitiesServiceFilter.match({a:[]}, {a:"a"}));

nit: single quotes like everywhere else in this file.
Attachment #8335404 - Flags: review?(fabrice) → review+
Duplicate of this bug: 940645
https://hg.mozilla.org/mozilla-central/rev/7398656bc7cc
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Keywords: verifyme
QA Contact: mvaughan → jsmith
Verified on trunk - the activity picker is appearing again & working with input file.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Verified that the activity picker appears on the following versions:

1.2 Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131205004003
Gaia: 0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
Gecko: af2c7ebb5967
Version: 26.0
Firmware Version: V1.2_20131115

1.3 Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131205040201
Gaia: 1dd0e5c644b4c677a4e8fa02e50d52136db489d9
Gecko: 725c36b5de1a
Version: 28.0a1
Firmware Version: V1.2_20131115
You need to log in before you can comment on or make changes to this bug.