Cannot drag apps or bookmarks with an icon by default

RESOLVED FIXED

Status

Firefox OS
Gaia::Homescreen
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

({regression})

unspecified
All
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.2 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
If an icon has not an icon and it shows one by default, we can't drag this app or bookmark
(Assignee)

Comment 1

4 years ago
When I say: "If an icon has not an icon" I mean when an app or bookmark has not an image icon :)
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Depends on: 896873
Keywords: regression
(Assignee)

Comment 2

4 years ago
Created attachment 813460 [details]
Patch v1

We removed the renderedIcon when it is by default from the descriptor then the loadRenderedIcon method fails, so if the renderedIcon is not defined we recover the icon by default blob calling to GridManager.getBlobByDefault
Attachment #813460 - Flags: review?(felash)
(Assignee)

Updated

4 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

4 years ago
status-b2g-v1.2: --- → affected
(Assignee)

Updated

4 years ago
Attachment #813460 - Flags: review?(felash) → review?(21)
(Assignee)

Comment 3

4 years ago
https://github.com/mozilla-b2g/gaia/commit/8d268639b5a4708285b0714d8cf6f8dc2def6ac4
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This is not a blocker issue but something that should have got fixed uplifted before 10/28 when approvals were being granted given its a regression.
blocking-b2g: leo? → -
Duplicate of this bug: 951971
This is a quite serious regression (see bug 951971 for a STR from a partner) and it should have been uplifted to v1.2 back at the time.

Requesting koi now, I know it's late. I don't understand why koi? was not asked when leo? was rejected, it should be the normal process.
blocking-b2g: - → koi?
Flags: needinfo?(bbajaj)
Flags: needinfo?(akeybl)
Too late for 1.2 at this point & this is not a regression from 1.1, so this is not a blocker for 1.2.
blocking-b2g: koi? → -
I find this is a pity that such a small patch can't be uplifted to 1.2, especially that it's in 1.3 for 2 months without regression.

Updated

4 years ago
Flags: needinfo?(bbajaj)
Was never a blocker given the STR we had in this bug, neither was this ready in time when approvals were given in 1.2 timeframe. Also QA highlighted that this is not a regression from 1.1.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 959586
Flags: needinfo?(akeybl)
You need to log in before you can comment on or make changes to this bug.