Print preview isn't working

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: troy, Assigned: don)

Tracking

Trunk
x86
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Don, print preview no longer works. Printing works, but when you bring up the
print preview window it just displays garbage, and none of the page frames are
being asked to display

This is on Windows

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

19 years ago
On the release build for 7/30, it still does not work.

1) Start apprunner
2) Go to a page on mozilla.org
3) Do a Print Preview - nothing happens

Par

Updated

19 years ago
Blocks: 11275
(Reporter)

Updated

19 years ago
Blocks: 16649

Updated

19 years ago
Blocks: 18471

Comment 2

19 years ago
Sorry for the spam, changing QA contact on printing bugs to our new printing
tester, Shrirang!

Updated

19 years ago
Blocks: 20203

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 3

19 years ago
Print Preview will now work.. it may get an assert due to a block frame layout
bug.

Comment 4

19 years ago
one of the constructor's in nsDocumentViewer.cpp was not initializing a member
that turned on or off the rendering.

Comment 5

19 years ago
I used the latest commercial build for today on windows. Did the following:

1) Start mozilla
2) Go to a page on mozilla.org
3) Open the File menu.
4) I see the Print Preview option grayed out and unusable.

However,I see this option enabled in Composer. But clicking on it opens a very
small fixed-size window(showing no contents).

Comment 6

19 years ago
This option has to be hooked up in Mozilla now.  I don't know who is responsible
to do this.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Assignee: dcone → don
Status: REOPENED → NEW

Updated

19 years ago
Resolution: FIXED → ---

Comment 7

19 years ago
I'm going to re-open and assign to don, leaving dcone on cc:list. Shrir, is the
behavior the same on all platforms?

Comment 8

19 years ago
Don, who gets to hook up print preview?

Comment 9

19 years ago
Sujay confirmed for me...happens on Linux and mac too. Thanks, sujay.
(Reporter)

Comment 10

19 years ago
You should not be re-opening this bug.

The bug was filed against viewer.exe, and that problem has been fixed.

If you want to report a new problem with mozilla.exe, then please file a new
bug...

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED

Comment 11

19 years ago
We aim to please here in browser qa, so shrir, please open a new bug and assign
to don to hook up print preview to mozilla.exe

I'll mark this one resolved/verified etc. as it sounds viewer is ok

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

19 years ago
No longer blocks: 18471

Updated

19 years ago
No longer blocks: 20203
You need to log in before you can comment on or make changes to this bug.