Closed Bug 923618 Opened 6 years ago Closed 6 years ago

[Mac] If WiFi is disabled geolocation does not work in Firefox 25 and later

Categories

(Core :: DOM: Geolocation, defect)

25 Branch
x86_64
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla27
Tracking Status
firefox24 --- unaffected
firefox25 + verified
firefox26 + verified
firefox27 + verified

People

(Reporter: pauly, Assigned: dougt)

References

Details

Attachments

(2 files)

Attached image geolocation.png
Open http://mozqa.com/data/firefox/geolocation/position.html

Actual results:
A warning shows up saying to enable the location services from Privacy preferences. But still doesn't work after checking the "enable location services" option in Privacy.

This is Mac OS specific only.
Repro on FF 25b2, 26.0a2, 27.0a1.
Works fine on FF 24.
Keywords: verifyme
This is odd. Everything's ok with the mozregression builds, but not if I download the builds manually.
Should this bug have tracking requested for Firefox 25?
Paul, could you create a little screencast for demonstration? that would be helpful for all of us who do not have a Mac at hand.
(In reply to Paul Silaghi [QA] from comment #1)
> This is odd. Everything's ok with the mozregression builds, but not if I
> download the builds manually.
Trying a manual range:
I can reproduce bug 888252 until 2013-07-16.
Starting with 2013-07-17 I can reproduce this bug.
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5976b9c673f8&tochange=0888e29c83a3
Keywords: qawanted
Unfortunately I don't see any obvious culprits in that range.
dougt, are you the right person to look into this? this would be one of our highest priority tracking issues, given loss of functionality.
Assignee: nobody → doug.turner
wfm.

Paul, did you disable location support on your mac?  Do you have wifi enabled?
The STR in comment 0 presumably involve starting with location support disabled (I assume that we otherwise wouldn't show that dialog), and then changing that after being prompted.
A more complete set of STR that describe the initial state of the system "Location Services" pref and the steps taken to change it would be helpful.
Flags: needinfo?(paul.silaghi)
Also, elaboration on what "still doesn't work" means. Does it start working if you  reload the page after enabling the system pref?
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #9)
> (I assume that we otherwise wouldn't show that dialog)

As I understand it, that's a system dialog not a Firefox dialog.

(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #11)
> Also, elaboration on what "still doesn't work" means. Does it start working
> if you  reload the page after enabling the system pref?

According to the screencast in comment 4, the answer to your question is "no".

Am I right in thinking that the provider in this case is the CoreLocation provider implemented in bug 874587? That landed on 2013-07-11, which is 6 days before the regression range identified in comment 5. Paul, could you confirm that it works as expected in nightly builds between 2013-07-12 and 2013-07-16?
(In reply to mjh563 from comment #12)
> Paul, could you
> confirm that it works as expected in nightly builds between 2013-07-12 and
> 2013-07-16?
On these builds I get a blank page after accessing the geolocation (bug 888252), so can't confirm.
Flags: needinfo?(paul.silaghi)
(In reply to Doug Turner (:dougt) from comment #8)
> Paul, did you disable location support on your mac?

(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #11)
> Also, elaboration on what "still doesn't work" means. Does it start working
> if you  reload the page after enabling the system pref?

With location service disabled - the warning from the screenshot shows up
With service enabled - unknown error acquiring position
So, geolocation won't work in both cases. Instead, it works in FF 24 both with service enabled/disabled. See the screencast in comment 4.

(In reply to Doug Turner (:dougt) from comment #8)
> Do you have wifi enabled?
No

(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #9)
> The STR in comment 0 presumably involve starting with location support
> disabled (I assume that we otherwise wouldn't show that dialog), and then
> changing that after being prompted.
First time I hit this, it was disabled. Didn't need to activate anything until this, it worked fine in FF 24 with location service disabled, as you can see in my screencast.

I see the same behavior on 2 Mac machines.
Any thoughts on comment 1 ? Couldn't be something related to rights & permissions ?
If WiFi is disabled, CoreLocation (the OS feature that geolocation uses) doesn't work.  Paul, can you enable WiFi and try again?
(In reply to Doug Turner (:dougt) from comment #15)
> If WiFi is disabled, CoreLocation (the OS feature that geolocation uses)
> doesn't work.

Which is a regression, because the default provider as used in Firefox 24 and below will return a position from the IP address if nothing more accurate is available.

Instead of returning an error to the Geolocation service in this situation, the CoreLocation provider should probably fall back to using Google's location service like the default provider does.
Mjh563, that is probably true.  We could also fallback to location.services.mozilla.com.
(In reply to Doug Turner (:dougt) from comment #15)
> Paul, can you enable WiFi and try again?
Indeed, works fine with wifi ON.
Summary: Geolocation is blocked on Mac in FF 25 and up → [Mac] If WiFi is disabled geolocation does not work in Firefox 25 and later
(In reply to Doug Turner (:dougt) from comment #15)
> If WiFi is disabled, CoreLocation (the OS feature that geolocation uses)
> doesn't work.

Is this true for all systems, including desktop macs? Sounds like a serious problem...
We should just backout the switch to corelocation and uplift it.  We probably can do more fancy stuff (like fallback to gls when there is no-wifi) later.
(In reply to Doug Turner (:dougt) from comment #20)
> We should just backout the switch to corelocation and uplift it.  We
> probably can do more fancy stuff (like fallback to gls when there is
> no-wifi) later.

+1 to a backout, as it's always our preference
I'll see about a build change that will disable it in preference for GLS.
Attached patch bug_923618Splinter Review
I think we can do something as simple as this.
Attachment #815712 - Flags: review?(josh)
Attachment #815712 - Flags: review?(josh) → review+
Blocks: 925346
Attachment #815712 - Flags: approval-mozilla-beta?
Attachment #815712 - Flags: approval-mozilla-aurora?
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/761097c088cd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Attachment #815712 - Flags: approval-mozilla-beta?
Attachment #815712 - Flags: approval-mozilla-beta+
Attachment #815712 - Flags: approval-mozilla-aurora?
Attachment #815712 - Flags: approval-mozilla-aurora+
Verified fixed FF 27.0a1 2013-10-14, Mac OS X 10.7.5
Verified fixed FF 25b8, 26.0a2 (2013-10-16) Mac OS X 10.8.4.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Blocks: 959987
You need to log in before you can comment on or make changes to this bug.