Closed Bug 959987 Opened 6 years ago Closed 6 years ago

Geolocation with timeout fails if WiFi is disabled

Categories

(Core :: DOM: Geolocation, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox30 --- affected
firefox31 --- verified
firefox32 --- unaffected
firefox33 --- unaffected

People

(Reporter: pauly, Assigned: garvan)

References

Details

29.0a1 (2014-01-14), Win 7 x64
STR:
1. Make sure WiFi is disabled
2. Open https://bugzilla.mozilla.org/attachment.cgi?id=763090 (testcase from bug 732923) and 'Share location'
3. Reload couple of times

AR: Error
ER: Success
Depends on: 973184
This works for me in nightly, but does not in FFox 30.
Closing as it WFM on nightly, technically, this was likely fixed at some point recently.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Garvan: is this bug reproducible in Beta 31 or Aurora 32? If is it reproducible in Beta or Aurora but works in Nightly, then we should find the fix and uplift it to the Aurora and Beta branches.

For bisecting Firefox regressions, I recommend "mozregression", a Python script that automates the tedious download+test+bisect cycle for testing archived Nightly builds

http://mozilla.github.io/mozregression/

For future reference, you can download archived Nightly builds from FTP here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014/
Status: RESOLVED → REOPENED
Flags: needinfo?(gkeeley)
Resolution: WORKSFORME → ---
Thanks for the info Chris, that's new for me, I'll try that out and report back.
Assignee: nobody → gkeeley
Flags: needinfo?(gkeeley)
Garvan: have you had a chance to test Beta 31 or Aurora 32? I tried, but I can't reproduce it on OS X (even on Firefox 30).

If this bug is fixed in Beta 31, then we can just close this bug as FIXED because Beta 31 will be released soon. If it's broken in Beta 31, then we should bisect between Aurora 32 and the Nightly 33 build that worked for you in comment 1 (build 2014-06-12) to find the fix, then uplift the fix to Beta 31.
Flags: needinfo?(gkeeley)
Works for me on Beta 31, marking Fixed. 

Took a while to get around to locating an ethernet cable, everything is Wifi here.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(gkeeley)
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Marking as verified based on comment 6.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.