invalid position:fixed rendering

RESOLVED FIXED in Firefox 26

Status

()

defect
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: lapsio3, Assigned: botond)

Tracking

25 Branch
Firefox 26
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 wontfix, firefox26 fixed, firefox27 fixed, relnote-firefox 26+)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Posted file test.html (obsolete) —
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.66 Safari/537.36

Steps to reproduce:

I made any element 100% width x 100% height with top:0, left:0 and fixed positioning. Example file attached as test.html


Actual results:

element is not properly rendered in Firefox 25 Beta. It seems to be shown under browser top bar (covered by browser top bar). However touch events are handled properly (as if element would be properly rendered) so I need to click about 1cm below rendered button to fire expected event


Expected results:

element should be displayed in right place (below top bar) like in Firefox <= 24.
(Reporter)

Updated

6 years ago
Severity: normal → major
Keywords: css2, mobile, platform
OS: Linux → Android
Priority: -- → P1
Hardware: x86_64 → ARM
Kats, is this is a core issue? If so, can you move it.
Severity: major → normal
Flags: needinfo?(bugmail.mozilla)
Priority: P1 → --
The attached test file appears to be using HTML appcache and isn't a full test case. Would you please update the test case with the actual HTML that is causing the problem?
Flags: needinfo?(bugmail.mozilla) → needinfo?(lapsio3)
(Reporter)

Comment 3

6 years ago
what do you want me to upload? I could add button, but it's not the point - the point is that on my Galaxy S3 even this pink rectangle is not properly rendered in Firefox Beta
Flags: needinfo?(lapsio3)
(Reporter)

Comment 4

6 years ago
(Reporter)

Comment 5

6 years ago
(Reporter)

Comment 6

6 years ago
(Reporter)

Comment 7

6 years ago
(Reporter)

Comment 8

6 years ago
Posted file correct test file
Attachment #813972 - Attachment is obsolete: true
(Reporter)

Comment 9

6 years ago
test file is available online at:
http://bt.staszic.waw.pl/test.html
(Reporter)

Comment 10

6 years ago
(In reply to Damian from comment #3)
> what do you want me to upload? I could add button, but it's not the point -
> the point is that on my Galaxy S3 even this pink rectangle is not properly
> rendered in Firefox Beta

Sorry I gave wrong file
Attachment #814108 - Attachment is patch: false
Attachment #814108 - Attachment mime type: text/plain → text/html
I can reproduce the behaviour on Fx25 but it's not there on Fx26. Presumably it was fixed by the same thing that fixed bug 903473 and bug 890910. Aaron, it's probably worth trying to track down what fixed this and getting it uplifted to beta as well. Using the regressionwindow-wanted since we don't have a fixwindow-wanted keyword :)
Speculative window as the test-case posted here (http://bt.staszic.waw.pl/test.html) on Nightly (m-c) widely demonstrates differing behaviour on the 2013-09-05 build (screen flickers black on pinch-zoom) from the 2013-09-04 (missing bottom of the window) build

http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2013-09-04&enddate=2013-09-05

Kats, I see bug 910322 in that range which is target milestoned as Firefox 26.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I found the difference you describe to be between the 09-05 build (missing bottom of window) and 09-06 (screen renders black).

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=77ed46bf4c1a&tochange=ab5f29823236

I'll build locally and bisect. I suspect bug 904533.
Yeah, so it was definitely bug 904533 that changed the "missing bottom of window" behaviour to the "screen renders black" behaviour. I suspect one of the (many) followups to that bug fixed the "screen renders black" behaviour. So at this point the options are:
1) leave everything as-is and make this bug wontfix for 25.
2) uplift bug 904533 + dependencies to 25 (and possibly 26, if they landed only on 27).

I'm leaning towards (1) because (2) is a high-risk option given how fragile that code is and how far into the beta cycle we currently are.
Duplicate of this bug: 903473
Duplicate of this bug: 890910
I'm going to mark this fixed since it is fixed in 26 and 27, and add the dependency on 904533 that fixed it. There are other bugs that were fixed by 904533 and it may get uplifted after all.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 904533
Resolution: --- → FIXED
Assignee: nobody → botond
Target Milestone: --- → Firefox 26
As per https://bugzilla.mozilla.org/show_bug.cgi?id=904533#c60 we are going to leave this unfixed in 25 because it's too late/too risky.
You need to log in before you can comment on or make changes to this bug.