Having to step out of a function twice so we can inspect its return value is confusing

RESOLVED FIXED in Firefox 64

Status

P3
normal
RESOLVED FIXED
5 years ago
3 months ago

People

(Reporter: taras.mozilla, Assigned: loganfsmyth)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 64
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(firefox64 fixed)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

5 years ago
I noticed firefox debugger requires multiple step-out-presses to step out of a function. Turns out Firefox has an intermediate step to show the return value. I found this confusing, thought that the extra step was a bug.

Chrome behaved as I expected.
This is by design, so that the user will have a chance to observe the returned (or thrown) value which is often ignored.
Pref?
(In reply to Panos Astithas [:past] from comment #1)
> This is by design, so that the user will have a chance to observe the
> returned (or thrown) value which is often ignored.

Right, and I agree that this is a good bit of info to show the user, but I think we can improve the UI/UX so that it doesn't appear that step out is broken *and* we still present the return/exception/yeild to the user.

I don't have any solid ideas for what this might look like yet, but I think it can be done.
Priority: -- → P3
This wouldn't happen to be related to bug 1052738, would it?
(In reply to Eddy Bruel [:ejpbruel] from comment #4)
> This wouldn't happen to be related to bug 1052738, would it?

No because you have to press resume twice there -- the breakpoint is actually getting hit two times on the same line. If you were stepping and on the second pause <return> was added to the variables view, then it would be, but that's not the behavior.
(In reply to Nick Fitzgerald [:fitzgen] from comment #3)
> (In reply to Panos Astithas [:past] from comment #1)
> > This is by design, so that the user will have a chance to observe the
> > returned (or thrown) value which is often ignored.
> 
> Right, and I agree that this is a good bit of info to show the user, but I
> think we can improve the UI/UX so that it doesn't appear that step out is
> broken *and* we still present the return/exception/yeild to the user.
> 
> I don't have any solid ideas for what this might look like yet, but I think
> it can be done.

How about instead of requiring the user to step out twice, we return to the caller immediately after the first step out, but show the returned value in the variables view under <return value>, then remove it again after the next step.
Sounds pretty good, but I'd like to see it in action and play with it to make sure that it isn't just as confusing in practice.
(In reply to Eddy Bruel [:ejpbruel] from comment #6)
> (In reply to Nick Fitzgerald [:fitzgen] from comment #3)
> > (In reply to Panos Astithas [:past] from comment #1)
> > > This is by design, so that the user will have a chance to observe the
> > > returned (or thrown) value which is often ignored.
> > 
> > Right, and I agree that this is a good bit of info to show the user, but I
> > think we can improve the UI/UX so that it doesn't appear that step out is
> > broken *and* we still present the return/exception/yeild to the user.
> > 
> > I don't have any solid ideas for what this might look like yet, but I think
> > it can be done.
> 
> How about instead of requiring the user to step out twice, we return to the
> caller immediately after the first step out, but show the returned value in
> the variables view under <return value>, then remove it again after the next
> step.

I like this.
Summary: step-out behavior feels broken → Having to step out of a function twice so we can inspect its return value is confusing
Assignee: nobody → ejpbruel
This came up in bug 1013219 as well.

I find the double stop a bit weird when using the debugger.
It's more reassuring when the debugging line marches through
the source -- when it stays in the same place I wonder if I clicked
the button or not.

Since the bytecode emitter knows what is going on, one possible
fix would be to extend Debugger.Script to expose this information.
Then the debugger would have enough information to allow both setting
a breakpoint on an empty function, and also to know to silently continue
past the final stepping stop in a function (presenting the user with
an apparent single stop due to the onPop handler).
Not actively working on this at the moment. Unassigning myself so other people can take a shot at this bug. However, I might take another shot at it when I get back from vacation.
Assignee: ejpbruel → nobody
That upstream ticket is the one I filed when I was going to investigate this bug and then
found out that the feature isn't working.  However, they aren't the same bug -- once the
upstream bug is fixed, the double-stepping problem (this bug) will remain.

FWIW my plan for fixing this bug was to add a new method to Debugger.Script that would
indicate whether a given offset held a return instruction.  Then, change the actor so that
a stop at a return instruction would install the onPop handler and continue.  This way,
breakpoints could still be set at the end of a function without undue complication; but
stepping would no longer double-stop.
Blocks: 1429101

Comment 13

8 months ago
Created attachment 8975247 [details] [diff] [review]
bug-923975-fix.patch
Attachment #8975247 - Flags: review?(jlaster)
Attachment #8975247 - Flags: review?(jimb)

Comment 14

8 months ago
(In reply to Hubert B Manilla from comment #13)
> Created attachment 8975247 [details] [diff] [review]
> bug-923975-fix.patch

I don't understand how this patch works. Maybe I don't understand the original bug, either.

I thought what's going on in the present code was this:

- We single-step to a return instruction, attributed to source location A. This is all fine from the user's point of view.

- We single-step again. The frame's onPop handler runs, with the frame still located at A. We call pauseAndRespond, meaning that the user sees a second pause at the same location, this time displaying the return value or thrown exception.

With this patch, it looks as if it's still the case that steppingType == "step" in the onPop handler, so the onPop handler will display a pause. How does this work?
Flags: needinfo?(b4bomsy)

Comment 15

8 months ago
Comment on attachment 8975247 [details] [diff] [review]
bug-923975-fix.patch

Review of attachment 8975247 [details] [diff] [review]:
-----------------------------------------------------------------

::: devtools/server/actors/thread.js
@@ +450,5 @@
> +          return packet;
> +        });
> +      }
> +
> +      const parentFrame = thread._getNextStepFrame(this);

Since you've set this.reportedPop, _getNextStepFrame is always going to return this.older. Why not just use that directly, here?

@@ +451,5 @@
> +        });
> +      }
> +
> +      const parentFrame = thread._getNextStepFrame(this);
> +      if (parentFrame && parentFrame.script) {

I believe there are not actually any Debugger.Frame objects that have a null script, so there's no need to test it here.

@@ +453,5 @@
> +
> +      const parentFrame = thread._getNextStepFrame(this);
> +      if (parentFrame && parentFrame.script) {
> +        const { onStep } = thread._makeSteppingHooks(originalLocation, "next", parentFrame);
> +        parentFrame.onStep = onStep;

When we're not catching exceptions, I think if this frame throws, its onPop handler is called, and then its parent's onPop handler is called next, with no intervening onStep calls. So I think if we don't set an onPop handler on parentFrame as well, hitting this path when an exception is being propagated will cause the debuggee to continue, and get away from the user. You should be able to adapt the test case to see whether I'm right about this.

If so, this code should behave more like _handleResumeLimit does for a real "next", and set on onPop handler for parentFrame as well.
Attachment #8975247 - Flags: review?(jimb) → feedback+
I'd also like to understand this patch.  I think a comment before the new "if" block
would go a long way.

Maybe the idea is to notice when a step pops a frame, and instead of reporting that stop,
report a stop in the outer frame?  Like comment #6 suggested.
I think showing the return in the outer frame could make sense. Let me see if i understand this correctly,

> function f() {
>   debugger
>   return 3
> }
> 
> f() + f()

Lets say the user pauses in f() on line 2 and steps out. 

I think it would be nice to pause at the 2nd f and show `<return> 3`. I wonder if it would always be possible to have the return value though given we are no longer in that environment. Also, does this work in the case of async functions e.g. `async function g() {}`.

Comment 18

8 months ago
(In reply to Jim Blandy :jimb from comment #14)
> (In reply to Hubert B Manilla from comment #13)
> > Created attachment 8975247 [details] [diff] [review]
> > bug-923975-fix.patch
> 
> I don't understand how this patch works. Maybe I don't understand the
> original bug, either.
> 
> I thought what's going on in the present code was this:
> 
> - We single-step to a return instruction, attributed to source location A.
> This is all fine from the user's point of view.
> 
> - We single-step again. The frame's onPop handler runs, with the frame still
> located at A. We call pauseAndRespond, meaning that the user sees a second
> pause at the same location, this time displaying the return value or thrown
> exception.
> 
> With this patch, it looks as if it's still the case that steppingType ==
> "step" in the onPop handler, so the onPop handler will display a pause. How
> does this work?

So this patch is trying to fix the step-out bug, we want to jump out to the caller frame on step-out, but step-in and step-over will still go normally and pause at the 
end of the function
Flags: needinfo?(b4bomsy)

Comment 19

8 months ago
(In reply to Tom Tromey :tromey from comment #16)
> I'd also like to understand this patch.  I think a comment before the new
> "if" block
> would go a long way.

Thanks. Good idea, i will add detailed comments.
 
> Maybe the idea is to notice when a step pops a frame, and instead of
> reporting that stop,
> report a stop in the outer frame?  Like comment #6 suggested.

Yes!

Comment 20

8 months ago
(In reply to Jason Laster [:jlast] from comment #17)
> I think showing the return in the outer frame could make sense. Let me see
> if i understand this correctly,
> 
> > function f() {
> >   debugger
> >   return 3
> > }
> > 
> > f() + f()
> 
> Lets say the user pauses in f() on line 2 and steps out. 
> 
> I think it would be nice to pause at the 2nd f and show `<return> 3`. I
> wonder if it would always be possible to have the return value though given
> we are no longer in that environment. Also, does this work in the case of
> async functions e.g. `async function g() {}`.

I like the idea, will try to. Wondering if it might be confusing... but i guess we can implement and see how it feels.
Good point on the async case, i'll test it out too.
just tried it out and it worked magically. I love it!

Comment 22

8 months ago
Created attachment 8980047 [details] [diff] [review]
bug-923975-updates.patch
Attachment #8975247 - Attachment is obsolete: true
Attachment #8975247 - Flags: review?(jlaster)
Attachment #8980047 - Flags: review?(jlaster)
Attachment #8980047 - Flags: review?(jimb)
Just to clarify, if we have this example `f(g())`and we're paused in `g` and step out, do we expect to be at `f` or inside of `f`? I would assume at `f`.

Comment 24

8 months ago
Yes so with `f(g())` we are at f. Interestingly though if we have f(g(h())). and we're paused in `h` and step out , it does not stop at `g` but goes straight inside `g`. stepping out from that then stops at `f`
oh, good to know... Any idea why? Jason, what would you expect to happen here?
Flags: needinfo?(jorendorff)

Comment 26

7 months ago
Created attachment 8984876 [details] [diff] [review]
bug-923975-updates-2.patch

- Fixed all the failing tests
Attachment #8980047 - Attachment is obsolete: true
Attachment #8980047 - Flags: review?(jlaster)
Attachment #8980047 - Flags: review?(jimb)
Attachment #8984876 - Flags: review?(jlaster)

Updated

7 months ago
Product: Firefox → DevTools
(Assignee)

Comment 28

4 months ago
Created attachment 9013033 [details]
Bug 923975 - Teach step out to leave the current frame. r=jimb
Comment on attachment 9013033 [details]
Bug 923975 - Teach step out to leave the current frame. r=jimb

Jason Laster [:jlast] has approved the revision.
Attachment #9013033 - Flags: review+

Comment 30

4 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c209b1927107
Teach step out to leave the current frame. r=jlast
FYI, bug 1314057 removed browser_dbg_stack-07.js. Not sure if that newly-added sub-test needs to be re-added elsewhere or not.
Assignee: nobody → lsmyth
Flags: needinfo?(jlaster)
Attachment #8984876 - Attachment is obsolete: true
Attachment #8984876 - Flags: review?(jlaster)
Blocks: 1495617
That test was re-added in other tests. Thanks for checking!
Flags: needinfo?(jorendorff)
Flags: needinfo?(jlaster)

Comment 33

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c209b1927107
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Backed out changeset c209b1927107 (bug 923975) for failing at mochitest/browser_dbg_rr_stepping-02.js, etc. removed obsolete files. a=backout

Backout link: https://hg.mozilla.org/mozilla-central/rev/7cda6e1eb528ba81b10548e858f91689b36dfe3b

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed,busted,exception,runnable&searchStr=dt6&selectedJob=202734204&revision=c209b19271072f5225e86bfe2f7b8b40511233e0

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=202734204&repo=autoland&lineNumber=23225

Log snippet: 
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Source is doc_rr_basic.html - 
15:49:25     INFO - Buffered messages logged at 15:49:22
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 22 expected 22 - 
15:49:25     INFO - Buffered messages logged at 15:49:23
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 25 expected 25 - 
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 26 expected 26 - 
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 27 expected 27 - 
15:49:25     INFO - Buffered messages logged at 15:49:24
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 33 expected 33 - 
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 32 expected 32 - 
15:49:25     INFO - Buffered messages logged at 15:49:25
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:49:25     INFO - Buffered messages finished
15:49:25     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js | Paused at line 23 expected 26 - 
15:49:25     INFO - Stack trace:
15:49:25     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/head.js:resumeThenPauseAtLineFunctionFactory/</<:92
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:l:59
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:eventSource/proto.emit:124
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/thread-client.js:_onThreadState:694
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:onPacket:876
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send/<:64
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:49:25     INFO - DevToolsUtils.executeSoon*resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:exports.executeSoon:57
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send:58
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:send:1031
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:receiveMessage:66
15:49:25     INFO - MessageListener.receiveMessage*resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:_addListener:40
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:ready:57
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame/</onActorCreated<:742
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:trackMessageManager:624
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame/<:837
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame:613
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/frame-proxy.js:connect:54
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webbrowser.js:BrowserTabList.prototype._getActorForBrowser:310
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webbrowser.js:BrowserTabList.prototype.getTab:347
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/root.js:onGetTab:345
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:onPacket:1313
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send/<:64
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:49:25     INFO - DevToolsUtils.executeSoon*resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:exports.executeSoon:57
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send:58
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:_sendRequest:747
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:_sendOrQueueRequest:731
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:request:621
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/root-client.js:getTab:253
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:getTab:342
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/target.js:createTargetForTab:89
15:49:25     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/target.js:forTab:38
15:49:25     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/head.js:attachDebugger:72
15:49:25     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-02.js:test:15
15:49:25     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1124
15:49:25     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:986
Flags: needinfo?(lsmyth)

Comment 35

4 months ago
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/5f65584c639c
Backed out changeset c209b1927107 for failing at mochitest/browser_dbg_rr_stepping-02.js, etc. a=backout
Status: RESOLVED → REOPENED
status-firefox64: fixed → ---
Resolution: FIXED → ---

Comment 36

4 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3599e95a53b7
Revert "Backed out changeset c209b1927107 for failing at mochitest/browser_dbg_rr_stepping-02.js, etc. a=backout"
Backed out changeset 3599e95a53b7 (bug 923975) for build bustage when reverting backout

Backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/5dce4548074f41c62aa86b3851900587640f7813

Failure push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=3599e95a53b7c3cdfe7b6ee049afe71e24713a9a

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=202937977&repo=mozilla-inbound&lineNumber=42100

[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package>   browser/chrome/browser/content/browser/places/bookmarkProperties.xul
[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package>   browser/chrome/browser/content/browser/places/bookmarkProperties2.xul
[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package>
[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package> Duplicates 12923 bytes:
[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package>   browser/chrome/icons/default/default128.png
[task 2018-10-02T19:09:51.945Z] 19:09:51     INFO -  package>   browser/chrome/browser/content/branding/icon128.png
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package>
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package> Duplicates 14117 bytes:
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package>   browser/features/formautofill@mozilla.org/chrome/content/autofillEditForms.js
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package>   browser/chrome/browser/res/payments/formautofill/autofillEditForms.js
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package>
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package> WARNING: Found 25 duplicated files taking 72115 bytes (uncompressed)
[task 2018-10-02T19:09:51.946Z] 19:09:51     INFO -  package> # Package mozharness
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.test_archive  mozharness /builds/worker/workspace/build/src/obj-firefox/dist/mozharness.zip
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> Wrote 525 files in 2377061 bytes to mozharness.zip in 0.22s
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> # Package JavaScript Shell
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> Packaging JavaScript Shell...
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> rm -f ../../dist/target.jsshell.zip
[task 2018-10-02T19:09:51.947Z] 19:09:51     INFO -  package> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.zip -C ../../dist/bin --strip /builds/worker/workspace/build/src/obj-firefox/dist/target.jsshell.zip js libmozglue.so  libnspr4.so libplds4.so libplc4.so
[task 2018-10-02T19:09:51.948Z] 19:09:51     INFO -  package> make[5]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/browser/installer'
[task 2018-10-02T19:09:52.998Z] 19:09:52     INFO -  package-tests> make[2]: Entering directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  package-tests> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.download_wpt_manifest
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  package-tests> Downloading wpt manifest
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  package-tests> make[2]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  /builds/worker/workspace/build/src/build/moz-automation.mk:84: recipe for target 'automation/package-tests' failed
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  make[1]: *** [automation/package-tests] Error 2
[task 2018-10-02T19:09:52.999Z] 19:09:52     INFO -  make[1]: *** Waiting for unfinished jobs....
[task 2018-10-02T19:09:53.745Z] 19:09:53     INFO -  buildsymbols> make[2]: Entering directory '/builds/worker/workspace/build/src/obj-firefox'
[task 2018-10-02T19:09:53.745Z] 19:09:53     INFO -  buildsymbols> rm -f 'dist/target.crashreporter-symbols.zip'
[task 2018-10-02T19:09:53.745Z] 19:09:53     INFO -  buildsymbols> /builds/worker/workspace/build/src/obj-firefox/_virtualenvs/init/bin/python -m mozbuild.action.symbols_archive 'dist/target.crashreporter-symbols.zip' /builds/worker/workspace/build/src/obj-firefox/dist/crashreporter-symbols
[task 2018-10-02T19:09:53.745Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.745Z] 19:09:53     INFO -  buildsymbols> 	"BadCertServer/852F5E27A892C636B025C11355A5DBD10/BadCertServer.sym"
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols> 	"GenerateOCSPResponse/2CC45203AE48D1DD4BB5D8EB71E72B5E0/GenerateOCSPResponse.sym"
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols> 	"OCSPStaplingServer/F20DB2337C77E36AF03E1A06F206CD4B0/OCSPStaplingServer.sym"
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.746Z] 19:09:53     INFO -  buildsymbols> 	"ShowSSEConfig/5B8A6E79ECF0914B55BB53CD7BBF43AA0/ShowSSEConfig.sym"
[task 2018-10-02T19:09:53.747Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.747Z] 19:09:53     INFO -  buildsymbols> 	"SmokeDMD/50B2D810128BC61DEE031788711394750/SmokeDMD.sym"
[task 2018-10-02T19:09:53.747Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.747Z] 19:09:53     INFO -  buildsymbols> 	"SymantecSanctionsServer/C4323405027C000293404BCBEE54FD7C0/SymantecSanctionsServer.sym"
[task 2018-10-02T19:09:53.747Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols> 	"TestAlgorithm/6A42C5F684AA24FB12A92B43EDD0A4AC0/TestAlgorithm.sym"
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols> 	"TestArguments/D0A090FFCAB7CCC4E9BF7B36F160B1380/TestArguments.sym"
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols> 	"TestArray/7EAD03C494E33FFF9254BA523551C8980/TestArray.sym"
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.748Z] 19:09:53     INFO -  buildsymbols> 	"TestArrayUtils/800FA8ABFC5D1E0DC38C5897CB0A6B950/TestArrayUtils.sym"
[task 2018-10-02T19:09:53.749Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.750Z] 19:09:53     INFO -  buildsymbols> 	"TestAtomics/5DF83984284C85933FE4B3F07938FD3A0/TestAtomics.sym"
[task 2018-10-02T19:09:53.750Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.750Z] 19:09:53     INFO -  buildsymbols> 	"TestBinarySearch/33E700BA1C76B80B67DA212032FDCC6F0/TestBinarySearch.sym"
[task 2018-10-02T19:09:53.751Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.751Z] 19:09:53     INFO -  buildsymbols> 	"TestBlockingProcess/616CB9748177CB3D1F3F3492BF7AA9EE0/TestBlockingProcess.sym"
[task 2018-10-02T19:09:53.751Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.751Z] 19:09:53     INFO -  buildsymbols> 	"TestBloomFilter/1DA7118C712789EA482010A93A2A66780/TestBloomFilter.sym"
[task 2018-10-02T19:09:53.752Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.752Z] 19:09:53     INFO -  buildsymbols> 	"TestBufferList/A797A465C33306301A0315EB5C118E0F0/TestBufferList.sym"
[task 2018-10-02T19:09:53.752Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.753Z] 19:09:53     INFO -  buildsymbols> 	"TestCasting/4F3A76D1AC8E7C432D332039BCA209BB0/TestCasting.sym"
[task 2018-10-02T19:09:53.753Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.753Z] 19:09:53     INFO -  buildsymbols> 	"TestCeilingFloor/BCCAB5703D92913448830E037393CDA20/TestCeilingFloor.sym"
[task 2018-10-02T19:09:53.753Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.754Z] 19:09:53     INFO -  buildsymbols> 	"TestCheckedInt/64AE30E005A7DE8CD93C51A3F61B5DBF0/TestCheckedInt.sym"
[task 2018-10-02T19:09:53.754Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.754Z] 19:09:53     INFO -  buildsymbols> 	"TestCountPopulation/8B02F30AA254EBE52C2C2FCA66E155680/TestCountPopulation.sym"
[task 2018-10-02T19:09:53.754Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.755Z] 19:09:53     INFO -  buildsymbols> 	"TestCountZeroes/C2FCCC48208006968C3057897B2B52BD0/TestCountZeroes.sym"
[task 2018-10-02T19:09:53.755Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.755Z] 19:09:53     INFO -  buildsymbols> 	"TestDefineEnum/23BC8BF742350C47BFFCB4ADA1B208870/TestDefineEnum.sym"
[task 2018-10-02T19:09:53.755Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.756Z] 19:09:53     INFO -  buildsymbols> 	"TestDoublyLinkedList/508F77F06E547F3CE4B02BB7C1273B410/TestDoublyLinkedList.sym"
[task 2018-10-02T19:09:53.756Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.756Z] 19:09:53     INFO -  buildsymbols> 	"TestEndian/C8435519CD2BC49C428835B31FCDB6E50/TestEndian.sym"
[task 2018-10-02T19:09:53.757Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.757Z] 19:09:53     INFO -  buildsymbols> 	"TestEnumSet/BA935316A21D50C5D892D79E097FA1DB0/TestEnumSet.sym"
[task 2018-10-02T19:09:53.757Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.757Z] 19:09:53     INFO -  buildsymbols> 	"TestEnumTypeTraits/8C010FD5336EEEBA9ED91326480D58AC0/TestEnumTypeTraits.sym"
[task 2018-10-02T19:09:53.758Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.758Z] 19:09:53     INFO -  buildsymbols> 	"TestEnumeratedArray/09597B4ED101B420C4AE76385FE4DBDB0/TestEnumeratedArray.sym"
[task 2018-10-02T19:09:53.758Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.758Z] 19:09:53     INFO -  buildsymbols> 	"TestFastBernoulliTrial/2E6AEAB5CF5E58CDC092403BDBAF7A8E0/TestFastBernoulliTrial.sym"
[task 2018-10-02T19:09:53.759Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
[task 2018-10-02T19:09:53.759Z] 19:09:53     INFO -  buildsymbols> 	"TestFloatingPoint/9301059B0DF9714BD5D22B2DF8E92FE30/TestFloatingPoint.sym"
[task 2018-10-02T19:09:53.759Z] 19:09:53     INFO -  buildsymbols>   Adding to "target.crashreporter-symbols.zip":
Flags: needinfo?(jlaster)
I think the issue is that the backout was actually two commits. Testing that hypothesis now.

Comment 40

4 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/9f50e3dd7b14
Revert "Backed out changeset 3599e95a53b7 for build bustage when reverting backout on a CLOSED TREE"
https://hg.mozilla.org/integration/mozilla-inbound/rev/e1ac0b6c2ca0
Revert "Backed out changeset c209b1927107 for failing at mochitest/browser_dbg_rr_stepping-02.js, etc. removed obsolete files. a=backout"
Backed out 2 changesets (bug 923975) for devtools failures at devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-04.js

Backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/8f9391de161be4102c09b98f464f3f5f216cd6fc

Failure push: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=e1ac0b6c2ca0830009c059ef62d0aaf421b1a73d&selectedJob=202970096

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=202970096&repo=mozilla-inbound&lineNumber=24628

15:03:22     INFO - TEST-PASS | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-04.js | Paused at line 20 expected 20 - 
15:03:22     INFO - Buffered messages logged at 15:03:22
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Buffered messages finished
15:03:22     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-04.js | Paused at line 21 expected 12 - 
15:03:22     INFO - Stack trace:
15:03:22     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/head.js:resumeThenPauseAtLineFunctionFactory/</<:92
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:l:59
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:eventSource/proto.emit:124
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/thread-client.js:_onThreadState:694
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:onPacket:876
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send/<:64
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:03:22     INFO - DevToolsUtils.executeSoon*resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:exports.executeSoon:57
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send:58
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:send:1031
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:receiveMessage:66
15:03:22     INFO - MessageListener.receiveMessage*resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:_addListener:40
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/child-transport.js:ready:57
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame/</onActorCreated<:742
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:trackMessageManager:624
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame/<:837
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:connectToFrame:613
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/targets/frame-proxy.js:connect:54
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webbrowser.js:BrowserTabList.prototype._getActorForBrowser:310
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/webbrowser.js:BrowserTabList.prototype.getTab:347
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/actors/root.js:onGetTab:345
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/server/main.js:onPacket:1313
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send/<:64
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:03:22     INFO - DevToolsUtils.executeSoon*resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:exports.executeSoon:57
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send:58
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:_sendRequest:747
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:_sendOrQueueRequest:731
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:request:621
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/root-client.js:getTab:253
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:getTab:342
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/target.js:createTargetForTab:89
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/client/framework/target.js:forTab:38
15:03:22     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/head.js:attachDebugger:72
15:03:22     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-04.js:test:15
15:03:22     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1124
15:03:22     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:986
15:03:22     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
15:03:22     INFO - GECKO(1960) | [ACTION] MAP_FRAMES  - {}
15:03:22     INFO - GECKO(1960) | [ACTION] SET_SELECTED_LOCATION  - {"type":"SET_SELECTED_LOCATION","source":{"id":"server1.conn83.child1/source26","url":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc_rr_basic.html","sourceMapURL":null,"isBlackBoxed":false,"isPrettyPrinted":false,"isWasm":false,"text":"","contentType":"text/html","loadedState":"loaded","relativeUrl":"http://example.com/browser/devtools/client/debugger/new/test/mochitest/examples/doc_rr_basic.html"},"location":{"sourceId":"server1.conn83.child1/source26","line":21,"column":2}}
15:03:22     INFO - GECKO(1960) | [ACTION] ADD_SCOPES [start] - {}
15:03:22     INFO - GECKO(1960) | [ACTION] ADD_EXTRA  - {"type":"ADD_EXTRA","extra":{}}
15:03:22     INFO - GECKO(1960) | [ACTION] MAP_SCOPES [start] - {}
15:03:22     INFO - GECKO(1960) | [ACTION] OUT_OF_SCOPE_LOCATIONS  - {}
15:03:22     INFO - GECKO(1960) | [ACTION] IN_SCOPE_LINES  - {}
15:03:22     INFO - GECKO(1960) | [ACTION] MAP_SCOPES [done] - {}
15:03:22     INFO - GECKO(1960) | [ACTION] EVALUATE_EXPRESSIONS  - {"type":"EVALUATE_EXPRESSIONS","inputs":[],"results":[]}
15:03:22     INFO - GECKO(1960) | [ACTION] RESUME  - {"type":"RESUME"}
15:03:22     INFO - GECKO(1960) | [ACTION] EVALUATE_EXPRESSIONS  - {"type":"EVALUATE_EXPRESSIONS","inputs":[],"results":[]}
15:03:22     INFO - GECKO(1960) | [ACTION] ADD_SCOPES [done] - {}
15:03:22     INFO - GECKO(1960) | [ACTION] PAUSED  - {"type":"PAUSED","why":{"type":"resumeLimit"},"frames":[{"id":"server1.conn83.child1/frame108","location":{"sourceId":"server1.conn83.child1/source26","line":20,"column":2},"displayName":"updateNumber"},{"id":"server1.conn83.child1/frame121","location":{"sourceId":"server1.conn83.child1/source26","line":12,"column":2},"displayName":"f"}],"selectedFrameId":"server1.conn83.child1/frame108","loadedObjects":[],"pauseInfo":{"why":{"type":"resumeLimit"}},"scopes":[]}
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xlink." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Console message: [JavaScript Warning: "Removed unsafe attribute. Element: svg. Attribute: xmlns." {file: "resource://devtools/shared/base-loader.js -> resource://devtools/client/shared/vendor/react-dom.js" line: 5811}]
15:03:22     INFO - Not taking screenshot here: see the one that was previously logged
15:03:22     INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/new/test/mochitest/browser_dbg_rr_stepping-04.js | Paused at line 20 expected 21 - 
15:03:22     INFO - Stack trace:
15:03:22     INFO - chrome://mochitests/content/browser/devtools/client/debugger/new/test/mochitest/head.js:resumeThenPauseAtLineFunctionFactory/</<:92
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:l:59
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/event-source.js:eventSource/proto.emit:124
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/thread-client.js:_onThreadState:694
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/client/debugger-client.js:onPacket:876
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send/<:64
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/ThreadSafeDevToolsUtils.js:exports.makeInfallible/<:109
15:03:22     INFO - DevToolsUtils.executeSoon*resource://devtools/shared/base-loader.js -> resource://devtools/shared/DevToolsUtils.js:exports.executeSoon:57
15:03:22     INFO - resource://devtools/shared/base-loader.js -> resource://devtools/shared/transport/local-transport.js:send:58
Flags: needinfo?(jlaster)
ugh, sorry. There were several test failures here...

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ddb70d2197248cf94d84718d6ee13e92e060d770
Flags: needinfo?(jlaster)

Comment 44

4 months ago
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/217d78349cb5
Teach step out to leave the current frame. r=jlast

Comment 45

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/217d78349cb5
Status: REOPENED → RESOLVED
Last Resolved: 4 months ago3 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

3 months ago
Flags: needinfo?(lsmyth)
You need to log in before you can comment on or make changes to this bug.