ensure we flush skia caches in low memory conditions

RESOLVED DUPLICATE of bug 927254

Status

()

RESOLVED DUPLICATE of bug 927254
5 years ago
5 years ago

People

(Reporter: gal, Assigned: snorp)

Tracking

Trunk
All
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
We should install a low memory observer and flush all skia caches. This will help reduce memory used by background processes as well. freeMemoryIfPossible() on SkCanvas is a start. We also want to purge the glyph cache I think (Term()?).
(Reporter)

Updated

5 years ago
Assignee: nobody → milan
:snorp has been looking at the Skia cache and possible flushing.  James, do we have a bug for that?  Is it covering this topic?
Flags: needinfo?(snorp)
Yeah I was looking at this at one point and have a patch somewhere. Need to finish it up.
Assignee: milan → snorp
Flags: needinfo?(snorp)
George, do you by any chance have what James was working on so that we can continue while he's on PTO?
Flags: needinfo?(gwright)
I don't :(
Flags: needinfo?(gwright)
This was fixed by bug 927254.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927254
You need to log in before you can comment on or make changes to this bug.