Closed Bug 924025 Opened 6 years ago Closed 6 years ago

Unable to log in at chase.com

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set

Tracking

(seamonkey2.23 fixed, seamonkey2.24 fixed)

RESOLVED FIXED
seamonkey2.25
Tracking Status
seamonkey2.23 --- fixed
seamonkey2.24 --- fixed

People

(Reporter: base12, Assigned: mcsmurf)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.2) Gecko/20100101 Firefox/10.0.2 (Beta/Release)
Build ID: 20131006003001

Steps to reproduce:

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 SeaMonkey/2.24a1
Build identifier: 20131006003001

1) Went to https://www.chase.com/
2) Tried to log in with valid account


Actual results:

Nothing happened


Expected results:

I should have been taken to the main page for my account.

I tried in safe mode and also using a clean profile. Interestingly I have no problem logging in with Firefox trunk nightly, 27.0a1 (2013-10-06), so the problem seems specific to SM. I first noticed the log-in problem on October 4, but I probably hadn't logged in before that for about a month.
On page load I see in Error Console
Error: Error: Permission denied to access property 'toString'
Entered some username/password, pressed Log In, get
Error: NS_ERROR_FAILURE: 
Source File: https://mfasa.chase.com/auth/js/mfp.js
Line: 4
Code:
for (var prop in navigator) {
This is on
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 SeaMonkey/2.24a1
Build identifier: 20130929003001
Here too:  https://chaseonline.chase.com/Logon.aspx
 
 
Would think it is a sniffing issue?
Or something to do with our SSL settings?

> problem seems specific to SM

Agreed.

You enter your un/pw, then click the 'Log on' button, but nothing happens.
If the un/pw were invalid, you should get a reply like:

> Unable to Log On

> We're sorry, but you used an User ID and/or password that doesn't match our
> records. Please try again. Or, click "Forgot your User ID and Password?" to
> restore your access.

But that does not happen.
Nor does a valid un/pw log you in.

FF does work.

Spoofing the UA (is general.useragent.override still correct?) to:

> Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

still does not work.
 
 
Opened an older SeaMonkey:

Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0 
Build identifier: 20130630011339

And that does work.

So then not likely a sniffing issue?
A regression.
Still the possibility of an SSL related issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
The error in Comment 1 reminds me a bit of Bug 858639 Comment 7. At that time mochitest-browser-chrome failed while it tried to "iterate" through the "window" object:
   112    this._globalProperties = Object.keys(window);

because of a missing .xpt file in the installer package manifest. Maybe we're having a similar problem here as Comment 1 also points to some code that iterates through a JavaScript object provided by the browser.
Broken (I believe it to be the first 2.23 Aurora):

Build identifier: 20130918013001
Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/0322470077b7

Works (as does SeaMonkey 2.22 release, & I believe it to be the last 2.22 Aurora):

Build identifier: 20130917013001
Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/b34ef6ca8f9e
 
 
> <mcsmurf>
> oh, Comment 1 reminds me of something
> specifically some strange bug related to some JS code accessing navigator object in JS
> which failed because of some file missing in our packages-manifest.in
> <thebot>	Bug 858639  RESO FIXED, Mochitest-browser-chrome fails since 20/03/2013
> One last comment on this for now, this JS error looks related:
> JavaScript error: chrome://mochikit/content/browser-test.js, line 112: NS_ERROR_FAILURE: Failure
> line 112:
> 112 this._globalProperties = Object.keys(window);
> ok, it was "window", not "navigator"
> but there a missing .xpt file in our installer packaging file cause some JS code to break
A better range, from Trunk:
 
 
Broken:

Build identifier: 20130813003001
Built from http://hg.mozilla.org/mozilla-central/rev/9ff2fa888c04

Works:

Build identifier: 20130812003001
Built from http://hg.mozilla.org/mozilla-central/rev/3d20597e0a07
Attached patch PatchSplinter Review
Turned out my assumption was right, we need to include two files in the package-manifest that are quite B2G only, but are still needed for desktop browser to work correctly. Easy bustage fix, so pushing directly to comm-central.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Pushed patch to comm-central: https://hg.mozilla.org/comm-central/rev/9e1457436952
This patch ported the package-manifest changes from Bug 883923.
Keywords: regression
Comment on attachment 828560 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): Bug 883923
User impact if declined: Websites may break randomly
Testing completed (on m-c, etc.): Installer packaging changes only, works fine on comm-central
Risk to taking this patch (and alternatives if risky): Trivial patch, the files itself have already been tested on Firefox desktop browser
String changes made by this patch: -
Attachment #828560 - Flags: approval-comm-beta?
Attachment #828560 - Flags: approval-comm-aurora?
Target Milestone: --- → seamonkey2.25
Comment on attachment 828560 [details] [diff] [review]
Patch

a=me for both comm-aurora and comm-beta
Attachment #828560 - Flags: approval-comm-beta?
Attachment #828560 - Flags: approval-comm-beta+
Attachment #828560 - Flags: approval-comm-aurora?
Attachment #828560 - Flags: approval-comm-aurora+
Confirmed working on today's Windows Nightly.
You need to log in before you can comment on or make changes to this bug.