Clean up ecma_6/Generators iterator tests

RESOLVED FIXED in mozilla27

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wingo, Assigned: wingo)

Tracking

unspecified
mozilla27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

5 years ago
tests/ecma_6/Generators includes a version of assertIteratorResult that has the expected values first, unlike the one in jit-tests/lib/iteration.js.  This patch will change the jstests to match the jittests, and to match the general (ACTUAL, EXPECTED) argument order.
(Assignee)

Comment 1

5 years ago
Created attachment 814310 [details] [diff] [review]
Clean up ecma_6/Generators iterator tests
(Assignee)

Updated

5 years ago
Assignee: nobody → wingo
(Assignee)

Updated

5 years ago
Attachment #814310 - Flags: review?(jwalden+bmo)
(Assignee)

Comment 2

5 years ago
Created attachment 814323 [details] [diff] [review]
More iterator test cleanups

As suggested by Waldo over IRC, this patch adds assertIteratorNext / assertIteratorDone helpers.
Attachment #814323 - Flags: review?(jwalden+bmo)

Updated

5 years ago
Attachment #814310 - Flags: review?(jwalden+bmo) → review+

Updated

5 years ago
Attachment #814323 - Flags: review?(jwalden+bmo) → review+
(Assignee)

Comment 3

5 years ago
Created attachment 818387 [details] [diff] [review]
Clean up ecma_6/Generators iterator tests  r=jwalden
(Assignee)

Updated

5 years ago
Attachment #814310 - Attachment is obsolete: true
(Assignee)

Comment 4

5 years ago
Created attachment 818388 [details] [diff] [review]
More iterator test cleanups  r=jwalden
(Assignee)

Updated

5 years ago
Attachment #814323 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Attachment #818387 - Attachment description: Clean up ecma_6/Generators iterator tests → Clean up ecma_6/Generators iterator tests r=jwalden
Attachment #818387 - Flags: review+
(Assignee)

Updated

5 years ago
Attachment #818388 - Attachment description: More iterator test cleanups → More iterator test cleanups r=jwalden
Attachment #818388 - Flags: review+
(Assignee)

Comment 5

5 years ago
Thanks for the review!
Keywords: checkin-needed
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/4d45af314d05
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/68149d83be3a
Status: NEW → ASSIGNED
Keywords: checkin-needed
OS: Linux → All
Hardware: x86_64 → All
https://hg.mozilla.org/mozilla-central/rev/4d45af314d05
https://hg.mozilla.org/mozilla-central/rev/68149d83be3a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(Assignee)

Updated

5 years ago
Duplicate of this bug: 924317
You need to log in before you can comment on or make changes to this bug.