Closed Bug 924479 Opened 6 years ago Closed 6 years ago

[Utility tray] It's easy to get utility tray shown even just click on the top of the app.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: alive, Assigned: etienne)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Open any app.
2. Click the header part of the app.

Expected:
UtilityTray shouldn't display.

Actual:
UtilityTray is shown very easily.

I think it's regressed from 902393.
blocking-b2g: koi+ → ---
How critical is this? It sounds like touch events are slightly off here, so I can't tell what the user impact is. Would this block user interaction at the top of the app as a result?
It's annoying but I cannot say it's blocking.
Duplicate of this bug: 924907
Assignee: nobody → etienne
It's actually blocking user interaction.

In the Sms app, for example, it makes it difficult to tap the back or edit button.
(In reply to Julien Wajsberg [:julienw] (in MozSummit until next monday) from comment #4)
> It's actually blocking user interaction.
> 
> In the Sms app, for example, it makes it difficult to tap the back or edit
> button.

If you feel strongly then, feel free to nominate to block.
Attached file Pointer to gaia PR
This patch makes you drag 1/5th of the screen down to open, and 1/5th of the screen up to close.
Attachment #814937 - Flags: review?(alive)
Comment on attachment 814937 [details]
Pointer to gaia PR

r=me, thanks!
Attachment #814937 - Flags: review?(alive) → review+
https://github.com/mozilla-b2g/gaia/commit/0511a0832d0fe9957363b352e59592f4b2fd0a93
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Can you ask for approval on this?
Duplicate of this bug: 928279
Nominating per the dupe for bad UX impact.
blocking-b2g: --- → koi?
blocking-b2g: koi? → koi+
Uplifted 0511a0832d0fe9957363b352e59592f4b2fd0a93 to:
v1.2: e7d00b98a845653bb9b4283b095ddd54ef6b1fd6
You need to log in before you can comment on or make changes to this bug.