Having VS2013 installed breaks VS2010 builds: unresolved _IID_ID2D1EffectImpl, _IID_ID2D1DrawTransform

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dmajor, Assigned: m_kato)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm using mozilla build 1.8.0 which I believe is latest.

STR:
Install VS2010
Launch a VC10 mozilla build window
Build the tree --> Works
Install VS2013
Launch a VC10 mozilla build window
Build the tree --> Fail

It looks like it's now trying to build some D2D1_1 stuff like RadialGradientEffectD2D1.cpp. If you only have VS2010 installed then we just skip these files.

Maybe this is related:
http://hg.mozilla.org/mozilla-central/file/64b497e6f593/configure.in#l7825
> if test "${OS_TARGET}" = "WINNT"; then
>  if $PERL -e "exit($MOZ_WINSDK_MAXVER < 0x06020000)"; then
>    MOZ_ENABLE_DIRECT2D1_1=1

Perhaps 2010 is seeing MAXVER==602 even though it uses the 601 SDK?
(Reporter)

Updated

5 years ago
Blocks: 914596
Why it sees MAXVER? It should see TARGETVER.

Comment 2

5 years ago
(In reply to Masatoshi Kimura [:emk] from comment #1)
> Why it sees MAXVER? It should see TARGETVER.

vs2012 can use sdk8.0 . the problem may be vs2010 trying to use sdk8.1
We should either
- Change the default target ver to 602 and require --with-windows-version=601 of those who are still using Win7 SDK to build the tree, or
- Just drop the support for Win7 SDK.
(Assignee)

Updated

5 years ago
Assignee: nobody → m_kato
Component: Build Config → MozillaBuild
Product: Core → mozilla.org
Version: Trunk → other
(Assignee)

Comment 4

5 years ago
Created attachment 814773 [details] [diff] [review]
Fix for mozilla-build
(Assignee)

Comment 5

5 years ago
Comment on attachment 814773 [details] [diff] [review]
Fix for mozilla-build

I forget updating msvc10.bat for 8.1 SDK.  Also, installer has to include vs2013 script.
Attachment #814773 - Flags: review?(ryanvm)
(Reporter)

Comment 6

5 years ago
(In reply to Makoto Kato (:m_kato) from comment #4)
> Created attachment 814773 [details] [diff] [review]
> Fix for mozilla-build

Was this intended for the other bug?
Bug 924745 - Having VS2013 installed breaks VS2010 builds: unresolved _IID_IDataObjectAsyncCapability
Doesn't it also fix this bug?
(Reporter)

Comment 8

5 years ago
Ah, you are right. Based on the MAXVER discussion, I thought this would need a different fix. But it seems that fixing the LIB path is also a solution. Hooray!
(Assignee)

Comment 9

5 years ago
(In reply to David Major [:dmajor] from comment #6)
> (In reply to Makoto Kato (:m_kato) from comment #4)
> > Created attachment 814773 [details] [diff] [review]
> > Fix for mozilla-build
> 
> Was this intended for the other bug?
> Bug 924745 - Having VS2013 installed breaks VS2010 builds: unresolved
> _IID_IDataObjectAsyncCapability

same issue.  We should dup of this.
Attachment #814773 - Flags: review?(ryanvm) → review+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-build/rev/778f3168ae13
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 928594
Blocks: 928594
No longer depends on: 928594
Duplicate of this bug: 924745
Duplicate of this bug: 942391
Can we make bug 942391 depend on this bug instead of duping it to this bug? They are definitely distinct issues. I don't have any of the causes (I don't have VS2013 installed) of this bug and I don't have any of the symptoms of this bug (I see different error messages than the ones described in this bug).
(Assignee)

Comment 14

5 years ago
(In reply to Tim Abraldes [:TimAbraldes] [:tabraldes] from comment #13)
> Can we make bug 942391 depend on this bug instead of duping it to this bug?
> They are definitely distinct issues. I don't have any of the causes (I don't
> have VS2013 installed) of this bug and I don't have any of the symptoms of
> this bug (I see different error messages than the ones described in this
> bug).

Because LIB environment value is incorrect on VS2010 script, this bug occurs.  Since LIB is incorrect, LINKER try to link incorrect library (then this issue occurs) if installed both Windows 8.0 SDK and Windows 8.1 SDK.  If not installed Windows 8.0 SDK, bug 942391's issue occurs.
Duplicate of this bug: 951135
Duplicate of this bug: 949483
You need to log in before you can comment on or make changes to this bug.