Closed Bug 924665 Opened 6 years ago Closed 6 years ago

BackgroundPageThumbs captures can finish twice

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- wontfix
firefox27 --- fixed

People

(Reporter: adw, Assigned: adw)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Bug 913171 moved the captureCallback call after _store completes, which is fine, but it also moved the destroy call, which introduces the possibility of _done being called twice: first on successful completion, and then, while the _store is pending, again when the timeout timer fires and calls notify.  destroy has to happen synchronously with the _done call so that _done isn't called twice.

Unrelatedly, destroy contains an erroneous Services.ww.unregisterNotification(this) that's left over from when we were using PB mode, so this patch also removes that.

Patch is based on bug 924651.
Attachment #814618 - Flags: review?(mhammond)
Attachment #814618 - Flags: review?(mhammond) → review+
https://hg.mozilla.org/mozilla-central/rev/daa8fbedef2f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Comment on attachment 814618 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 913171
User impact if declined: minimal
Testing completed (on m-c, etc.): tryserver with this patch and two, related others I'd like to uplift: https://tbpl.mozilla.org/?tree=Try&rev=c8eda3703066
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none

Patch applies cleanly to Aurora.
Attachment #814618 - Flags: approval-mozilla-aurora?
Attachment #814618 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 814618 [details] [diff] [review]
patch

Whoops, I meant to cancel these approval requests earlier today.  We're not planning on uplifting this anymore because we're not going to uplift bug 927688 to Aurora/26 after all.

I won't undo the a+, but again, we decided not to uplift this.
You need to log in before you can comment on or make changes to this bug.