[B2G][Music] The Music continues to play when the USB mode is enabled and phone is plugged in to computer

RESOLVED DUPLICATE of bug 928558

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 928558
4 years ago
4 years ago

People

(Reporter: Shilpa Suresh, Assigned: Mahsa Mojtahedi)

Tracking

({regression})

unspecified
1.3 Sprint 3 - 10/25
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:koi+, b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun2)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 815031 [details]
logcat

Description:
When the phone is plugged into the computer with USB mode enabled. The Music app neither stops playing the song nor displays the warning "Music can not be used while phone is plugged in.Unplug to play the music" message. The Music continues to Play.

Repro Steps:
1) Updated Buri to Build ID: 20131009004001
2) Launch the Music app
3) Tap on any song to play it
4) Go to Settings and enable USB storage
5) Plug in the USB cable from the laptop to the phone
6) Observe that the Music does not stop playing. 

Actual:
The Music continues to play when the USB mode is enabled and phone is plugged in to computer 

Expected:
The Music stops playing and displays the warning 
message

Environmental Variables
Device: Buri v 1.2 aurora Mozilla RIL
Build ID: 20131009004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/e5edb484e2a9
Gaia: 672c47bf94b69a329e0aacb9228a6aa16ade6226
Platform Version: 26.0a2
Firmware Version: US_20130912

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/runtests/run/2330/env/347/?&pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=8517
See attached: logcat
(Reporter)

Comment 1

4 years ago
The issue does not reproduce on v 1.1 Leo
Environmental Variables
Device: Leo v 1.1.0 Mozilla RIL
Build ID: 20131009041203
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/c630289d6388
Gaia: 53e2a70d85fb3748d0768218a5efffe5806073f0
Platform Version: 18.1
RIL Version: 01.01.00.019.238 
Firmware Version: V10c
There's probably an important reason why this is the case, but I'd need someone who knows this feature more to clarify why.
blocking-b2g: --- → koi?

Comment 3

4 years ago
The expectation to have the music pause and display warning (in reply to comment 2)
blocking-b2g: koi? → koi+

Updated

4 years ago
QA Contact: mdavydova

Comment 4

4 years ago
Regression range:

Buri v1.2 Build ID: 20130717030208 – does not reproduce
Gecko: http://hg.mozilla.org/mozilla-central/rev/582ffcd0459a
Gaia: f8740f5cd78f44a1063463cd96794f124c5b754e
Platform Version: 25.0a1 

Buri v1.2 Build ID: 20130718030209 - reproduces
Gecko: http://hg.mozilla.org/mozilla-central/rev/f26e4c26ce4a
Gaia: af0e322d36d2a863afd05d0ead5a9e8fd8254f7a
Platform Version: 25.0a1
Keywords: regressionwindow-wanted

Comment 5

4 years ago
Mahsa, Please take a look at this.

Thanks!
Assignee: nobody → mmojtahedi

Updated

4 years ago
Depends on: 912609
(Assignee)

Comment 6

4 years ago
Actual is expected based on a change in AutoMounter (bug https://bugzilla.mozilla.org/show_bug.cgi?id=876782). The resolution of bug https://bugzilla.mozilla.org/show_bug.cgi?id=912609 will resolve this issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(In reply to Mahsa Mojtahedi from comment #6)
> Actual is expected based on a change in AutoMounter (bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=876782). The resolution of bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=912609 will resolve this issue.

That's a feature, which won't block the release because we can't take features at this point. This bug as cited is a regression and needs to be fixed independently of bug 912609.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to Jason Smith [:jsmith] from comment #7)
> (In reply to Mahsa Mojtahedi from comment #6)
> > Actual is expected based on a change in AutoMounter (bug
> > https://bugzilla.mozilla.org/show_bug.cgi?id=876782). The resolution of bug
> > https://bugzilla.mozilla.org/show_bug.cgi?id=912609 will resolve this issue.
> 
> That's a feature, which won't block the release because we can't take
> features at this point. This bug as cited is a regression and needs to be
> fixed independently of bug 912609.

I'm not sure that this bug is a regression.

Basically, prior to the current behaviour (introduced by bug 876782) any apps which had files open would be forcebly terminated. This would often have side-effects, like killing the media server, which then causes gallery and video to not work properly. See bug 871383, bug 870327, and bug 861488 

The only way of "fixing" this bug is to notify the user that USB Mass Storage isn't being enabled because some files are open.

Determining the form that notification should take is what bug 883335 is for.
I agree with Dave. This is not a bug, but a feature. This is not fixable in the Music app or in the Video app.
 
Bug 912609 is a severe regression in the settings app that we need to fix.  (That bug calls itself a user story, but it describes a regression, not feature work.)

I've just nominated 912609 as koi? for the second time.  (Dave, maybe you'd prefer to have that nomination on 883335 instead. I'm not sure what the difference between the two bugs is.)
I got clarity on this from an email thread and above discussion. The test case itself here is no longer valid, so we need to disable the associated test case. However, the change that resulted from the auto mounter changes caused a UX fallout in bug 912609 per the discussion above, so we need to fix that address the UX fallout. Closing this out as WONTFIX then.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX

Comment 11

4 years ago
Test case 8517 has been disabled.
Target Milestone: --- → 1.3 Sprint 3 - 10/25
Now that bug 928558 has landed, the Music app now gets notified that the volume is going to be shared and it stops playing.

We should be able to confirm this, and probably close this bug as a duplicate of bug 928858.
Based on the rel driver discussion, I think you are right - this is a dupe of bug 928858.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 928858

Updated

4 years ago
Duplicate of bug: 928558

Updated

4 years ago
No longer depends on: 912609
You need to log in before you can comment on or make changes to this bug.