Pause integrated media player/mute audio on incoming calls

RESOLVED DUPLICATE of bug 1249579

Status

()

RESOLVED DUPLICATE of bug 1249579
5 years ago
2 years ago

People

(Reporter: rene, Unassigned)

Tracking

24 Branch
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911155223

Steps to reproduce:

Incoming call while website with audio is opened (background sound, audio/video stream, HTML5 audio/video tag).


Actual results:

Call audio is mixed with audio from Firefox.


Expected results:

Media playback of audio/video files is paused/realtime stream is muted while phone calls.
(Reporter)

Updated

5 years ago
OS: Linux → Android
Hardware: x86_64 → All
thought we already handled this (bug 809558)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(wjohnston)
We had to disable that in everything but apps. Would be nice to look for a solution here. It looks like this is typically done by monitoring the phone state [1]. We already do that in other places [2]. kinetic, is there an easy way to notify the audio system when we want it to mute (even though the app may still be in the foreground...)? Or would you rather build this into the cube implementation?

[1] http://stackoverflow.com/questions/5610464/stopping-starting-music-on-incoming-calls
[2] http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/GeckoApp.java#239
Flags: needinfo?(wjohnston) → needinfo?(kinetik)
Possibly we want to implement Audio Focus support (http://developer.android.com/training/managing-audio/audio-focus.html) in libcubeb, where loss of focus causes (at least) the stream to be muted.
Flags: needinfo?(kinetik)

Comment 4

4 years ago
This is a big problem when receiving calls as there is no way to mute the sound when the call is incoming on android 4.4.4. This means in order to answer a call without having background d sound from the media playing you first have to ignore the call, which isn't ideal.

Updated

4 years ago
Duplicate of this bug: 1119837

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249579
You need to log in before you can comment on or make changes to this bug.