Closed Bug 925538 Opened 6 years ago Closed 6 years ago

Synchronous file picker is broken

Categories

(Firefox for Android :: General, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 27
Tracking Status
firefox25 + fixed
firefox26 + fixed
firefox27 --- verified

People

(Reporter: wesj, Assigned: wesj)

Details

Attachments

(1 file)

Last fixup for file pickers, I implemented show() using some common code in PromptService.js. They're deprecated, but we should make them work.
Attached patch PatchSplinter Review
I stole some code from PromptService that I shouldn't have.
Assignee: nobody → wjohnston
Attachment #815608 - Flags: review?(mark.finkle)
Attachment #815608 - Flags: review?(mark.finkle) → review+
Comment on attachment 815608 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 874689
User impact if declined: Trying to use the synchronous file picker api is busted. The API is deprecated, but add-ons may try to use it anyway. It works on desktop, so it creates more work for them to figure out why the api doesn't also work on mobile.
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): We could not fire these dom events for file pickers with little affect on the real world.
String or IDL/UUID changes made by this patch: None.
Attachment #815608 - Flags: approval-mozilla-beta?
Attachment #815608 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/8804ec54fbcb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
I'm hoping kbrosnan can verify no new regressions to the file pickers prior to our final beta, in case we need to take another forward fix (or back this out).
Flags: needinfo?(kbrosnan)
Keywords: verifyme
Tested nightly and aurora with people.mozilla.org/~wjohnston/abouttests.xpi in aurora the synchronous file picker button does not work. In nightly it fires the same intent as the async one.
Flags: needinfo?(kbrosnan)
Keywords: verifyme
Attachment #815608 - Flags: approval-mozilla-beta?
Attachment #815608 - Flags: approval-mozilla-beta+
Attachment #815608 - Flags: approval-mozilla-aurora?
Attachment #815608 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.