[Bluetooth][Certification] HFP TC_AG_TWC_BV_02_I & 03_I FAILED

RESOLVED INVALID

Status

defect
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: wachen, Assigned: jaliu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Test case : TC_AG_TWC_BV_03_I started
	- SDP Service record for PTS: 'Handsfree HF' successfully registered
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- AT: RING
	- AT: Received +CLIP: "0958028036",129
	- AT: Incoming call established
	- HCI: Audio Connection enabled
	- AT: Received +CCWA: "0956222967",129
	- FATAL ERROR (AT): The response to the following AT command has timed out: AT+CHLD=2
	- MTC received unexpected EXIT message from AT component
	- FATAL ERROR (AT): PTS Error: congestion: TS_AT_block called when OK pending
	- HCI: Audio Connection disabled
	- AT: SPP disconnect succeeded
	- MTC: Test case ended
Final Verdict : Inconclusive


Test case : TC_AG_TWC_BV_02_I started
	- SDP Service record for PTS: 'Handsfree HF' successfully registered
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- The IUT claims support for the following eSCO LMP packet types: EV3, 2-EV3, 
	- AT: SPP connect succeeded
	- AT: Service Level Connection established
	- AT: post SLC command sequence complete
	- AT: RING
	- AT: Received +CLIP: "0958028036",129
	- AT: Incoming call established
	- HCI: Audio Connection enabled
	- AT: Received +CCWA: "0956222967",129
	- AT:  WARNING: (call=0) received during processing of AT+CHLD=1 request
	- Unexpected CM from CP_AT_MTC
	- HCI: Audio Connection disabled
	- FATAL ERROR (AT): CM_CALL indicates CALL be brought down when CALL state is CIND_CALL_INACTIVE
	- AT: SPP disconnect succeeded
	- MTC: Test case ended
Final Verdict : Inconclusive
No longer depends on: 924775
I tested "TC_AG_TWC_BV_02_I" & "03_I" with mozilla-b2g26_v1.2 and both of them are pass.
However, I did got an Error that said "The response to the following AT command has timed out" once.

The error didn't occurred after I retried the PTS test, I'm not sure this is because I didn't follow PTS instructions well at first time or something else goes wrong.

P.S. My device is Inari.
Hi Walter, per comment 3, would you mind giving it another try with current v1.2? Thanks.
Flags: needinfo?(wachen)
(In reply to Eric Chou [:ericchou] [:echou] from comment #4)
> Hi Walter, per comment 3, would you mind giving it another try with current
> v1.2? Thanks.

Hi Walter,
Please feel free to contact me if you encounter any problems during TC_AG_TWC_BV_02_I & 03_I testing.
Thank you.
Assignee: nobody → jaliu
Hi,

I just verified this no longer failed. Thanks for Jamin's help and I will now close this as invalid :P
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(wachen)
Resolution: --- → INVALID
Great. Thank you both. :)
Blocks: 939706
No longer blocks: 939706
You need to log in before you can comment on or make changes to this bug.