Closed Bug 939706 Opened 6 years ago Closed 6 years ago

[Bluetooth][PTS][Meta] Bluetooth PTS test (v1.2 in aurora)

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: wachen, Assigned: jaliu)

References

Details

Attachments

(8 files)

Please provides PICS configuration file, and QA will start to perform the PTS test. Final test result report also will be uploaded here for tracking.

Bugs will be added as PTS goes.
No longer depends on: 924800, 919262, 922469, 922470, 924775, 924798, 925660
Summary: [Bluetooth][PTS][Meta] Bluetooth PTS monthly test (Sep. 2013) → [Bluetooth][PTS][Meta] Bluetooth PTS test (v1.2 in aurora)
Assignee: nobody → jaliu
QA Contact: wachen
Attached file HFP pics
Attached file HSP pics
Attached file OPP pics
Attached file A2DP pics
Attached file AVRCP pics
Attached file IOPT pics
Hi Walter,
All pics are here, Please use 11/21 hamachi build [1] to test. Please feel free to let me know if you have any testing problem.
Thank you very much.

[1] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2g_ril/hamachi-eng-mozilla-b2g26_v1_2-20131121004002-ril01.02.00.019.102.zip

These PTS test cases are hard to perform.
I think SQA found skip them until we find better way to do these test.
HFP AG_ACS - Requires to close SCO but keep Service level connection.
HFP AG_TCA - Requires to close SCO but keep Service level connection.
HFP AG_OOR - Requires to close Bluetooth, and enable cellular
HFP AG_TRS - Requires to close cellular but enable Bluetooth
HFP AG_PSI - Requires battery change

SQA don't have to pass this test case IOPT TC_COD_BV_02_I, since it has been implemented under HFP15 in PTS.

I'll put more information for PTS test and update Bug 924800 later.
Hi Walter,
Sorry for any inconvenience, I need to modify my last comment.
Please use this ptv build [2] to perform the PTS testing.
Thank you.
[2] https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g26_v1_2-hamachi/2013/11/2013-11-24-00-40-01/
Eric Chang:
A2DP passed
AVRCP under test
HFP under test

Walter Chen: 
IOPT passed
-TC_COD_BV_02_I skipped
OPP passed
HSP under test
HSP - AG_OAC - TC_AG_OAC_BV_01_I
AVRCP - TG - CEC - TC_TG_CEC_BV_02_I 
Are failing and we will confirm again tomorrow.

HFP has about 20 failed cases and we will confirm it again tomorrow.

After confirmed, we will be opening bugs.
We will get the trace and open another 2 bugs for devs.

===============================================================
<AVRCP>
===============================================================
- TG
[f] TC_TG_CEC_BV_02_I

===============================================================
<HSP>
===============================================================
AG_OAC
[f] TC_AG_OAC_BV_01_I

===============================================================
<HFP>
===============================================================
Everything is good till battery part.

AG_IIA
[s] TC_AG_IIA_BV_01_I -> contains battery testing, skipped.
AG_IIC
[s] TC_AG_IID_BV_03_I -> contains battery testing, skipped.

AG_PSI
[s] TC_AG_PSI_BV_03_I -> contains battery testing, skipped.

AG_IIA
[s] TC_AG_IIA_BV_02_I -> contains battery testing, skipped.
[s] TC_AG_IIA_BV_05_I -> contains battery testing, skipped.

AG_IID
[s] TC_AG_IID_BV_04_I -> contains battery testing, skipped.
[s] TC_AG_IID_BV_03_I <--battery related

AG_IIC
[s] TC_AG_IID_BV_02_I -> contains battery testing, skipped.
Depends on: 943752
Depends on: 943753
Test run finished, and 2 bugs opened accordingly.
Flags: needinfo?(jaliu)
Hi Walter, Eric Chang
Thank you for your effort.

Bluetooth team will handle 943752 and 943753 recently.
Best regards.
Flags: needinfo?(jaliu)
943752 and 943753 verified okay with Bluetooth PTS 4.9, log attached.

Gaia      fcf1c2fe020c29da4755621cbffdc1a333a43be9                           │  
Gecko     http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/129ad3c335a5 │  
BuildID   20131216004002                                                     │  
Version   26.0                                                               │  
ro.build.version.incremental=eng.archermind.20131114.105818                  │  
ro.build.date=Thu Nov 14 10:58:33 CST 2013
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.