Defect - Missing win32 localized Metro builds due to broken bookmark creation

VERIFIED FIXED in Firefox 26

Status

P1
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: mbrubeck)

Tracking

26 Branch
Firefox 27
All
Windows 8

Firefox Tracking Flags

(firefox26+ verified, firefox27 verified)

Details

(Whiteboard: [mozmill] feature=defect c=tbd u=tbd p=1, URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
As it can be seen on the following URL we have a lot of broken l10n builds on mozilla-aurora due to a failure in creating the bookmarks in the repack process:

Generating: bookmarks
e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\obj-firefox\browser\metro\locales\import\Makefile:52:0$ e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/obj-firefox/_virtualenv/Scripts/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py \
  -I e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/l10n/mn/browser/profile/bookmarks.inc \
  -DAB_CD=mn \
  e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/browser/metro/locales/import/../generic/profile/bookmarks.json.in > ../bookmarks.json
e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\obj-firefox\browser\metro\locales\import\Makefile:52:0: command 'e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/obj-firefox/_virtualenv/Scripts/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py \
  -I e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/l10n/mn/browser/profile/bookmarks.inc \
  -DAB_CD=mn \
  e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/browser/metro/locales/import/../generic/profile/bookmarks.json.in > ../bookmarks.json' failed, return code 1
evaluation from e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\config\recurse.mk:44:44:14:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py -C import export' failed, return code 2
e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\config\rules.mk:694:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py export' failed, return code 2
e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\obj-firefox\browser\locales\Makefile:149:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py -C ../metro/locales AB_CD=mn XPI_NAME=locale-mn' failed, return code 2
Traceback (most recent call last):
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 492, in <module>
    main()
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 477, in main
    pp.handleCommandLine(None, True)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 169, in handleCommandLine
    self.do_include(f, False)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 462, in do_include
    self.handleLine(l)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 241, in handleLine
    self.write(aLine)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 139, in write
    filteredLine = self.applyFilters(aLine)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 124, in applyFilters
    aLine = f[1](aLine)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 420, in filter_substitution
    return self.varsubst.sub(repl, aLine)
  File "e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/config/Preprocessor.py", line 418, in repl
    raise Preprocessor.Error(self, 'UNDEFINED_VAR', varname)
__main__.Error: ('e:\\builds\\moz2_slave\\m-aurora-w32-l10n-ntly-0000000\\build\\mozilla-aurora\\browser\\metro\\locales\\generic\\profile\\bookmarks.json.in', 3, 'UNDEFINED_VAR', 'bookmarks_title')
program finished with exit code 2

Some affected locales are: ta-LK, ur, mn, hi-IN,
(Reporter)

Updated

5 years ago
Component: General Automation → Build Config
Product: Release Engineering → Core
QA Contact: catlee
Version: other → 26 Branch
(Reporter)

Comment 1

5 years ago
On Oct 7th we have the first indications of this issue:
https://secure.pub.build.mozilla.org/builddata/buildjson/l10n_reports/2013-10-07.txt

Comment 2

5 years ago
This is a metro build issue, moving over.

The problem is that the l10n-merge deps in browser/metro/locales/import are wrong.

Currently, it's

vpath book%.inc $(LOCALE_SRCDIR)/profile
ifdef LOCALE_MERGEDIR
vpath book%.inc $(LOCALE_SRCDIR)/profile
vpath book%.inc @top_srcdir@/$(relativesrcdir)/en-US/profile
endif


but it needs to mimic what we do for desktop

ifdef LOCALE_MERGEDIR
vpath book%.inc $(LOCALE_MERGEDIR)/browser/profile
endif
vpath book%.inc $(LOCALE_SRCDIR)/profile
ifdef LOCALE_MERGEDIR
vpath book%.inc @srcdir@/en-US/profile
endif


The full complexity of the double ifdef is required.
status-firefox26: --- → affected
tracking-firefox26: --- → ?
Component: Build Config → Build Config
Product: Core → Firefox for Metro
tracking-firefox26: ? → +
Marco - can you get someone on this?
Assignee: nobody → mmucci

Updated

5 years ago
Blocks: 838081
Summary: Missing win32 localized builds due to broken bookmark creation → Defect - Missing win32 localized builds due to broken bookmark creation
Whiteboard: [mozmill] → [mozmill] [triage] feature=defect c=tbd u=tbd p=0
(Reporter)

Updated

5 years ago
Summary: Defect - Missing win32 localized builds due to broken bookmark creation → Defect - Missing win32 localized Metro builds due to broken bookmark creation
(Reporter)

Updated

5 years ago
OS: Windows 7 → Windows 8
I'm bumping the importance of this because Windows is our #1 platform, and Aurora is where localizers do their work. We're getting close to the next uplift, and it's important for localizers to be able to verify their work.
Severity: major → critical
(Assignee)

Comment 5

5 years ago
Created attachment 817285 [details] [diff] [review]
patch

This patch just implements Pike's fix from comment 2.
Assignee: mmucci → mbrubeck
Status: NEW → ASSIGNED
Attachment #817285 - Flags: review?(gps)

Updated

5 years ago
QA Contact: jbecerra
Whiteboard: [mozmill] [triage] feature=defect c=tbd u=tbd p=0 → [mozmill] feature=defect c=tbd u=tbd p=0

Updated

5 years ago
Blocks: 925788
No longer blocks: 838081
Whiteboard: [mozmill] feature=defect c=tbd u=tbd p=0 → [mozmill] feature=defect c=tbd u=tbd p=1

Updated

5 years ago
Priority: -- → P1

Updated

5 years ago
Attachment #817285 - Flags: review?(gps) → review+
(Assignee)

Comment 7

5 years ago
Backed out along with bug 923596 because one of them caused Metro to crash/hang:
https://hg.mozilla.org/integration/fx-team/rev/5ec2fca2c0b0
(Assignee)

Comment 9

5 years ago
Comment on attachment 817285 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): enabling Metro on Aurora

User impact if declined: broken l10n repacks on Aurora

Testing completed (on m-c, etc.): landed on fx-team; green on TBPL

Risk to taking this patch (and alternatives if risky): this is a Metro-only change that should only affect Metro localization.

String or IDL/UUID changes made by this patch: None.
Attachment #817285 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/5e659bcf02bc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Attachment #817285 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/37471d163234
status-firefox26: affected → fixed
status-firefox27: --- → fixed

Comment 12

5 years ago
catlee mailed me this:



I've been working on a 26.0b1 staging release for the past week. Just wanted to check that these issues were on your radar:

ta-LK seems to be missing bookmarks_title for metro?
__main__.Error: ('e:\\builds\\moz2_slave\\rel-m-beta-w32_rpk_6-000000000\\mozilla-beta\\browser\\metro\\locales\\generic\\profile\\bookmarks.json.in', 3, 'UNDEFINED_VAR', 'bookmarks_title')

mn also:
__main__.Error: ('e:\\builds\\moz2_slave\\rel-m-beta-w32_rpk_4-000000000\\mozilla-beta\\browser\\metro\\locales\\generic\\profile\\bookmarks.json.in', 3, 'UNDEFINED_VAR', 'bookmarks_title') 

Chris, can you check that you have the fix of this bug in your staging test?
No, I don't have that fix. I started the staging release prior to it landing. Do I need to re-build the en-US builds, or can I just transplant that fix and re-run my repacks?

Comment 14

5 years ago
I suspect you need to rebuild en-US, as repacks update to the en-US revision to make merge-l10n work, and that's where the culprit is.
While testing this for iteration #17, with the ur Aurora build from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/10/2013-10-31-00-40-03-mozilla-aurora-l10n/ on Win 8 64-bit, it works in Metro mode: I did a little browsing and added some bookmarks.

Is there anything else QA should cover, in order to verify this bug? Thanks!
Flags: needinfo?(mbrubeck)
(Assignee)

Comment 16

5 years ago
Nope, I think that's good.
Status: RESOLVED → VERIFIED
Flags: needinfo?(mbrubeck)
(Reporter)

Comment 17

5 years ago
It's all fine now, yes! There are no more such failures listed at:
https://secure.pub.build.mozilla.org/builddata/buildjson/l10n_reports/latest.txt
(Reporter)

Updated

5 years ago
status-firefox26: fixed → verified
status-firefox27: fixed → verified
You need to log in before you can comment on or make changes to this bug.