Closed Bug 925912 Opened 9 years ago Closed 9 years ago

Create Docker images or chroot tarballs from puppetagain systems

Categories

(Infrastructure & Operations :: RelOps: Puppet, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dustin, Unassigned)

Details

Right now, if a dev wants access to a system that's functionally identical to a releng system, there are two options: set up a whole PuppetAgain environment and build one, or borrow one from releng.  The first is really time-consuming, so nobody's ever done it (that I know of).  The second is pretty easy.  But what if we had an in-between option?

There are lots of tools out there that allow you to run lightweight virtual environments on linux: good old "chroot" and Docker come to mind.

Could we release either a chroot tarball, built from a freshly-imaged, stripped linux build host, periodically?  Similarly, could we do that with Docker, so devs can really easily spin up an LXC containing a build system from a certain date?
Dupe of bug 896023?
Why did nobody copy me on that :(
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896023
Ah, now that I carefully read the first comment, that's about archiving the mock environments, not the whole system.  So, different (and probably more useful to you).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
My contention in bug 896023 is that because we are using chroots for the build environment, the "outer" operating system is all but irrelevant. It's only important for RelEng AFAICT.
Assignee: nobody → relops
We talk about this as an idea every few months.  However, it's not required yet, so no reason to work on it.  Re-open if/when it's required.
Severity: normal → enhancement
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.