Indicate the purpose of command line searches to getSubmission

RESOLVED DUPLICATE of bug 1177443

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 1177443
4 years ago
2 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

+++ This bug was initially created as a clone of Bug #925892 +++

Currently command line (CLI) searches (-search <term>) cannot be distinguished from the others because there is no purpose argument passed to getSubmission.

I think we should add a purpose (regardless of whether it's wanted by search partners) so we can then add a warning to getSubmission when no purpose argument is passed (i.e. it is undefined). This will help get bugs on file for accidentally omitted purpose arguments (e.g. bug 925898) and warn people like the Metro team that they are missing these.
I think I did the same search :) We also don't provide a purpose for alias-triggered searches (i.e. that go through getShortcutOrURIAndPostData).

Warning when it is omitted is a good idea, though we also have other consumers (metro/android/etc.) that aren't on board with the purpose stuff yet. And I think there are probably some edge cases where it doesn't make sense, so not sure how to handle that.
+1 for adding this.  I'd be surprised if this was more than noise, I've long since forgotten the feature existed...
Assignee: MattN+bmo → nobody
Status: ASSIGNED → NEW
Bug 1177443 is adding the "system" purpose for these and bug 1181645 covers making purpose required.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1177443
You need to log in before you can comment on or make changes to this bug.