Closed Bug 925990 Opened 6 years ago Closed 6 years ago

Profile has pink text on top of it

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 27

People

(Reporter: heroldtom, Assigned: past)

References

Details

Attachments

(2 files, 1 obsolete file)

Attached image screenshot.jpg
I am using nightly 27.0a1 from 23/10/11.

When I record a profile the "graph" gets overdrawn with Pink text saying: [Object Object]. Anton checked out and rules out addons/extensions and probably some other stuff. (ask him personally)

See the attached screenshot.
I'm going to look into this.
Assignee: nobody → past
Status: NEW → ASSIGNED
This is caused by bug 867757 which changed markers to be objects instead of strings, and bug 918825 has increased the number of such markers. I don't think displaying the markers in the graph makes sense any longer, especially when you zoom in a particular area of the graph, where the text just looks stretched and ugly.

What I'd like to see is these events to appear as vertical bars with different colors per category/type and display a legend somewhere that explains what each color stands for. Maybe even show tooltips when hovering over these bars. I'm not sure how far the profiler UI rewrite has progressed though, and whether it makes sense to do this in Cleopatra.
Blocks: 918825, 867757
We've changed how markers are displayed in our repo to be much nicer. You should by default hide non text markers.
Duplicate of this bug: 930955
Attached patch Ignore non-string markers (obsolete) — Splinter Review
Benoit, you mean like this? Which markers are going to be plain strings?

I tried to just use marker.name, but the display was too cluttered even with the right labels and zooming in needs more work as it still results in ugly text.
Attachment #822307 - Flags: review?(bgirard)
Comment on attachment 822307 [details] [diff] [review]
Ignore non-string markers

Going forward all markers will an object. Maybe you want to do it if the type is tracing.

http://mxr.mozilla.org/mozilla-central/source/tools/profiler/ProfilerMarkers.cpp#71
Attachment #822307 - Flags: review?(bgirard) → review-
OK, in that case I think the best short-term solution is to not display markers altogether. Displaying them properly can be done after the UI rewrite.
Attachment #822378 - Flags: review?(anton)
Attachment #822307 - Attachment is obsolete: true
Attachment #822378 - Flags: review?(anton) → review+
https://hg.mozilla.org/mozilla-central/rev/60c2fea83c0f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 27
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.