Any Java usage will cause mozilla to freeze.

VERIFIED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
VERIFIED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Timothy Wood, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
RedHat RPMS of mozilla 0.9.2-0
Latest Java Plugin
------
Going to a site like java.sun.com causes something to freeze the browser.  JVM
Process is defunct (according to ps -ax).  Killing all JVM processes spawned by
mozilla will cause the browser to crash completely, but ?cleanly? (it seems). 
Following error given after killing JVM processes causes crash.

INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable
I think this is a dupe of bug 84093.
Bug 84093 contains a workaround.....

Reporter: Please reopen if you disagree...

*** This bug has been marked as a duplicate of 84093 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
LD_ASSUME_KERNEL=2.2.5, mentioned in the bug report "related" to this one does
not fix the problem.  This has got to be a Mozilla problem and I'll tell you why
I think so. I was using mozilla pre0.9.1-4 until about 4 days ago, when I
downloaded 0.9.2-0, using the same JVM under the same OS (have not reloaded it
or anything) and never had the smallest trouble with a Java enabled page.  I
installed 0.9.2-0 and bang, Java pages lock mozilla with the afore mentioned
error(s).
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

17 years ago
This works for me perfectly.
However, your description of the status of the java_vm processes leads me to
conclude you may be running into something I run too once.
Did you ln -s your plugins from the netscape directory? If so, make sure that
cpPack1.jar is NOT on the mozilla plugins directory and try again. That jar is
for java on netscape 4.x, I think.

As far as I can see, java has been working pretty fine with me (redhat 6.2-7.1)
(Reporter)

Comment 4

17 years ago
Nope.  The only JARs in my mozilla Java2 Directory are:

i8n.jar
sunrsasign.jar
javaplugin_l10n.jar
javaplugin.jar
rt.jar
I still fail to see how anything except the browser code can be the problem when
all I did was change browser versions.  Unless something in this version of
mozilla is calling the jre I have installed instead of the plugin jre.  Any
thoughts on that?

Comment 5

17 years ago
OJI bug
Assignee: ashuk → edburns
Component: Java APIs for DOM → OJI
QA Contact: avm → shrir
(Assignee)

Comment 6

17 years ago
I've read this bug report, but after trying it with 0.9.2 and JDK1.3.1 on RH 7.0
I have to say that it works.  

WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
I'm using RH 7.1 if that makes any difference.  Also, is there any way that I
can tell if mozilla is using my j2re instead of the jre plugin?  Maybe an
environment variable or something?
(Reporter)

Comment 8

17 years ago
I relinked the oji in the mozilla plugins directory to the oji in my j2re
directory and everything works now.  It's pretty slow at times (first time I hit
a java page it takes around 60 second to initalize the java) and the memory use
is rediculous (have a look http://www.ovnet.com/~diyab/java_vm.gtop.jpg ) but at
least it works.
Status: RESOLVED → CLOSED

Comment 9

17 years ago
pls do not 'close' a bug since the product is still alive. The final resolution 
should be 'verified'. reopening to do that...
Status: CLOSED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 10

17 years ago
r
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 11

17 years ago
v
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.