Closed Bug 926283 Opened 7 years ago Closed 7 years ago

CSS Tools unnecessarily translate color names to hex in url() definition

Categories

(DevTools :: Inspector, defect, major)

27 Branch
x86
Windows XP
defect
Not set
major

Tracking

(firefox26 unaffected, firefox27+ verified)

RESOLVED FIXED
Firefox 27
Tracking Status
firefox26 --- unaffected
firefox27 + verified

People

(Reporter: alex, Assigned: miker)

References

()

Details

(Keywords: regression, verifyme)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131009055629

Steps to reproduce:

In options of editor i prefer view colors in hex mode, but this is not important. 

I want to see a page what contains some style like this:

<!DOCTYPE html>
<style type="text/css">
div {background:url('http://eu.battle.net/d3/static/images/item/icon-bgs/orange.png');}
</style>
<div>something</div>



Actual results:

When I inspect element in Inspector it shows me this style for div:
url("http://eu.battle.net/d3/static/images/item/icon-bgs/#FFA500.png") ...;
so URL became invalid, the orange.png became #ffa500.png.


Expected results:

it should not find color keywords inside url() block.
Severity: normal → major
Component: Untriaged → Developer Tools: Inspector
This sounds like bug 923884. It should be fixed if you update to the current nightly.
Thank you, I've updated nightly, but no. This is different bug. 
In bug 923884 they fixed replace in markup view. In Inspector, bug still exists in 27.0a1 (2013-10-13)
Right. It seems to be OK in the markup view but it's shown wrong in the styles box (Rules and Computed). Is that what you mean?

Could you attach a screenshot of it, just to be clear where the problem is?
Thanks. It looks like a similar problem to bug 923884, but affecting the style inspector rather than the markup view.
Regression window(fx-team)
Good:
http://hg.mozilla.org/integration/fx-team/rev/184a0076278b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130917075536
Bad:
http://hg.mozilla.org/integration/fx-team/rev/220ce292a894
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130917084033
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=184a0076278b&tochange=220ce292a894

Suspect:
e4e9ca3868d3	Michael Ratcliffe — Bug 911748 - Add default color dropdown to devtools options panel. r=jwalker
Blocks: 911748
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 918716 will fix this.
Assignee: nobody → mratcliffe
Depends on: 918716
Summary: web inspector translated color names to hex when it's not needed, like in url() defenition → CSS Tools unnecessarily translate color names to hex in url() definition
Bug 918716 should have fixed that... can you try with the latest nightly.
Yes, that seems to have fixed it.
Fixed in bug 918716
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Thank you.
Keywords: verifyme
Target Milestone: --- → Firefox 27
Attached image screenshot.JPG
Verified as fixed with latest Aurora (build ID: 20131030004000). Please see in the screenshot that the correct behavior is now displayed.
QA Contact: manuela.muntean
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.