Closed Bug 926305 Opened 6 years ago Closed 6 years ago

Duplicate paragraph when I press ENTER key in CKEditor

Categories

(Core :: DOM: Core & HTML, defect)

27 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox27 + verified

People

(Reporter: alice0775, Assigned: bzbarsky)

References

Details

(Keywords: regression, Whiteboard: [good first verify] [testday-20140116])

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/a50141faaab9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131013030202


Steps To Reproduce:
1. Open http://ckeditor.com/demo#full
2. Move caret the binging of "Apollo 11 was the spaceflight..." 
3. Press ENTER key

Actual Results:
Apollo 11Apollo 11 was the spaceflight that landed the first humans, Americans Neil Armstrong and Buzz Aldrin, on the Moon on July 20, 1969, at 20:18 UTC. Armstrong became the first to step onto the lunar surface 6 hours later on July 21 at 02:56 UTC.


Apollo 11 was the spaceflight that landed the first humans, Americans Neil Armstrong and Buzz Aldrin, on the Moon on July 20, 1969, at 20:18 UTC. Armstrong became the first to step onto the lunar surface 6 hours later on July 21 at 02:56 UTC.

Expected Results:

Apollo 11 was the spaceflight that landed the first humans, Americans Neil Armstrong and Buzz Aldrin, on the Moon on July 20, 1969, at 20:18 UTC. Armstrong became the first to step onto the lunar surface 6 hours later on July 21 at 02:56 UTC.

Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/c52358389897
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131011183931
Bad:
http://hg.mozilla.org/mozilla-central/rev/73f37c7a3860
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131011185030
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c52358389897&tochange=73f37c7a3860


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b4c3caf8f741
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131011085612
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ccf11ae08ba2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131011093009
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b4c3caf8f741&tochange=ccf11ae08ba2

Regressed by:  Bug 882541 or Bug 925495
In local build
Last Good: 61092280cb2a
First Bad: ccf11ae08ba2

Regressed by :
ccf11ae08ba2	Boris Zbarsky — Bug 882541 part 4. Treat undefined as missing for optional WebIDL arguments. r=khuey,ms2ger
No longer blocks: 925495
cc'ing myself since this impacts work on MDN content.
Should be fixed by backout of bug 882541.
CKEditor has this code:

  clone:function(b,g){var a=this.$.cloneNode(b)

Note what happens if clone() is called with no arguments.  This will pass an explicit undefined to cloneNode.  We used to treat that as "deep == false", but with the patch in bug 882541 this is treated as deep == true.

Changing cloneNode like so:

  Node cloneNode();  // calls the other overload with deep == true
  Node cloneNode(boolean deep);

fixes this issue.  I've filed https://www.w3.org/Bugs/Public/show_bug.cgi?id=23565 to get the spec fixed.
Assignee: nobody → bzbarsky
This is fixed as filed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Whiteboard: [good first verify]
Whiteboard: [good first verify] → [good first verify] [testday-20140116]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.