Closed Bug 926585 Opened 6 years ago Closed 6 years ago

[B2G] [Contacts] Select All / Deselect button text are not visible when importing Outlook/Google contacts

Categories

(Core :: Graphics, defect)

26 Branch
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED WORKSFORME
blocking-b2g koi+

People

(Reporter: amaxwell, Assigned: nical)

References

Details

(Keywords: regression, Whiteboard: burirun2)

Attachments

(3 files)

Attached image Screenshot of Issue
Description:
When importing contacts from Outlook, the Select All / Deselect All button text will not be visible after selecting a contact.

Repro Steps:
1) Updated to Buri Build ID:  20131014004003 Mozilla RIL
2) From the homescreen, select contacts/settings/import Contacts/Outlook
3) Enter username and password of an account with contacts
4) Select a contact

Actual:
Select/deselect text in buttons are not visible, when contacts are selected

Expected:
Text fields are always visible

Environmental Variables:
Device: Buri v1.2 (Aurora) Mozilla RIL
Build ID:  20131014004003
Gecko:   d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
Gaia:  690f28662ace
Base Image: 20130912

Notes: 
Repro frequency: 100%
Only occurs in Outlook Import
does not occur on v1.1
Attached file LogCat of Issue
Duplicate of this bug: 926586
Summary: [B2G] [Contacts] [Outlook] Select All / Deselect button text are not visible when importing Outlook contacts → [B2G] [Contacts] Select All / Deselect button text are not visible when importing Outlook/Google contacts
That's a strange regression - might be a gecko regression maybe?
blocking-b2g: --- → koi?
QA Contact: sparsons
This issue does not reproduce on 1.1 Build ID: 20131014041201

Gaia   680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
SourceStamp cb2a1a27a94c
BuildID 20131014041201
Version 18.0

This issue started to reproduce on the Buri 1.2 Aurora Build ID: 20131014004003

Gaia   d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
SourceStamp 690f28662ace
BuildID 20131014004003
Version 26.0a2

Last working Buri 1.2 Aurora Build ID: 20131013004004

Gaia   d0f0110f6a907ef386134dc693f5dc5a632a0e9e
SourceStamp 818ef9b4096c
BuildID 20131013004004
Version 26.0a2
QA Contact: sparsons
koi+ for regression.
blocking-b2g: koi? → koi+
I've tested with Unagi both on v1.2 and master is working perfectly. 

As Jason points out this might be a Gecko issue on the Buri device.
(In reply to Jose M. Cantera from comment #6)
> I've tested with Unagi both on v1.2 and master is working perfectly. 
> 
> As Jason points out this might be a Gecko issue on the Buri device.

Hmm...this is starting to sound like a GFX regression specifically.
Blocks: GFXB2G1.2
Component: Gaia::Contacts → Graphics
Product: Boot2Gecko → Core
Version: unspecified → 26 Branch
This issue is also occurring when selecting contacts from Facebook. Screenshot attached: TextDisappear_Facebook.png
Dan, lets see if you can dig through this and see what you can find.
Assignee: nobody → dglastonbury
Dan's looking at another bug, :nical, can you take a look at this one?  This is a 1.2 blocker so it preempts any other work.  Thanks.
Assignee: dglastonbury → nical.bugzilla
Flags: needinfo?(nical.bugzilla)
I get this in the logcat when reproducing on Hamachi:

E/memalloc(  140): /dev/pmem: No more pmem available
E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
W/GraphicBufferAllocator(  140): alloc(320, 460, 2, 00000133, ...) failed -12 (Out of memory)
E/memalloc(  140): /dev/pmem: No more pmem available
E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
W/GraphicBufferAllocator(  140): alloc(320, 460, 2, 00000133, ...) failed -12 (Out of memory)

It very much looks like our "no graceful fallback to shmem" problem when we run out of pmem.
Flags: needinfo?(nical.bugzilla)
Could this be bug 918671 as well ? The graphical issue is similar...
(In reply to Nicolas Silva [:nical] from comment #12)
> I get this in the logcat when reproducing on Hamachi:
> 
> E/memalloc(  140): /dev/pmem: No more pmem available
> E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(  140): alloc(320, 460, 2, 00000133, ...) failed
> -12 (Out of memory)
> E/memalloc(  140): /dev/pmem: No more pmem available
> E/msm7627a.gralloc(  140): gralloc failed err=Out of memory
> W/GraphicBufferAllocator(  140): alloc(320, 460, 2, 00000133, ...) failed
> -12 (Out of memory)
> 
> It very much looks like our "no graceful fallback to shmem" problem when we
> run out of pmem.

So we need a base image with bug 905882 then to see this fixed, right?
(In reply to Jason Smith [:jsmith] from comment #14)
> So we need a base image with bug 905882 then to see this fixed, right?

That's what I expect but I just bricked my hamachi so I can't test it and give you a solid confirmation just now.
We have a base 1.2 image now (with non-working wifi), but that should allow us to still test this via using data. Can someone retest this with the 1.2 base image & with the latest gaia/gecko changes included on top?
Keywords: qawanted
Outlook import is there; it's not selectable w/ just Data Network.  Is that a bug?

Gaia   2ef9bc3c7a6de228b63e6ba3613eb0c0dd639c59
BuildID 20131105151351
Version 26.0a2
1.2 Buri

Will retest on our own gecko/gaia on top of OEM build after finishing further OEM testing
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #17)
> Outlook import is there; it's not selectable w/ just Data Network.  Is that
> a bug?

Might be. Probably filing that as a separate bug.
(In reply to Jason Smith [:jsmith] from comment #18)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #17)
> > Outlook import is there; it's not selectable w/ just Data Network.  Is that
> > a bug?
> 
> Might be. Probably filing that as a separate bug.

Probably worth filing as a separate bug*
This issue is NOT reproducing for me anymore on the 11/12/2013 1.2 build with the 20131104 base image. I tested importing from Facebook, Gmail, and Outlook.

Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131112004004
Gaia: 35b1c6b669b7bf08126df451221113e72642abca
Gecko: 566e850868c7
Version: 26.0
RIL Version: 01.02.00.019.106
Base Image: 20131104
Keywords: qawanted
QA Contact: mvaughan
Hrm:

Gaia:     377eb71506d8790d3c3280d82ac007ff4525b7e0
Gecko:    c15f5d7e0d7ebff5f8edef0745f144cd1552e34c
BuildID   20131112123250
Version   28.0a1
Base Build : US_V1.2_20131111.cfg
Buri

Selecting Outlook is possible with our build; having said that, I get an error 
"We're unable to complete your request"  Apparently even though I haven't logged in, it thinks I've logged in.  Seems like a separate bug?

comment 17 would be an OEM bug; this seems like it might be a new bug that got introduced today?  Not sure.
Sounds like we can close this out per comment 20 then.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Naoki, did you file another bug for this?
Flags: needinfo?(nhirata.bugzilla)
For comment 21?

No, I did not; because I wasn't sure if it might be an issue with my own build and wanted to test it out on a releng build before I reported it.

In today's build I do not see the issue : 
Gaia:     71063dd91bc8cbb15ba335236ed67a1c5058bd58
Gecko:    http://hg.mozilla.org/mozilla-central/rev/cf378dddfac8
BuildID   20131121040202
Version   28.0a1

unless you have wifi you aren't able to import outlook nor gmail.
Buri
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.