[B2G][Contacts] A user is not returned to the previous screen after exporting a contacts

RESOLVED DUPLICATE of bug 910188

Status

RESOLVED DUPLICATE of bug 910188
5 years ago
5 years ago

People

(Reporter: sarsenyev, Assigned: fcampo)

Tracking

unspecified
1.2 C4(Nov8)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: burirun2)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 816856 [details]
2013-10-14-11-14-53.png

Description:" 
When exporting a contact for the second time, after selecting the contact a user is returned to the different screen, where unable to return to the "Settings"

Repro Steps:
1) Updated Buri to BuildID: 20131014004003
2) Open the "Contacts" from home screen
3) Tap the "Settings" "cogwheel"
4) Navigate to the "Export Contacts"
5) Select "SIM card"
6) Select any contact from the list
7) Tap the "Export" button
8) Repeat steps 5-7
9) In "Settings" button tap the "Done" button

Actual:
After exporting a contact for the first time a user is returned to "Export Contacts" screen
When exporting a contact for the second time, the user is returned to "Settings: screen and when tapping the "Done" button, the user  is returned to the "Contacts" screen where is no option to return to the "Settings

Expected:
(Describe the behavior you expected to have observed)

Environmental Variables:
Device: (example: Buri v1.2 Mozilla RIL)
BuildID: 20131014004003
Gaia: d562c8f6eaed158bf5afa556f10c2f2e8ae8137f
Gecko: 690f28662ace
Version: 26.0a2
Firmware Version: 
Notes: US_20130912

Repro frequency: 100%
https://moztrap.mozilla.org/manage/cases/?filter-id=9889
See attached: screenshot
This bug is missing expected behavior. Can you include that?
Flags: needinfo?(sarsenyev)
(Reporter)

Comment 2

5 years ago
I apologies, my browser is crashed and the bug was submitted without my permission

Expected result:
The user is returned to the previous "Contacts" screen when the user can continue to "export" the contacts
Flags: needinfo?(sarsenyev)
Sounds like a broken UX. A video would help clarify this a bit better.
blocking-b2g: --- → koi?
(Reporter)

Comment 4

5 years ago
Created attachment 816866 [details]
returned the first time
(Reporter)

Comment 5

5 years ago
Created attachment 816867 [details]
returned the second time
(Reporter)

Comment 6

5 years ago
Created attachment 816868 [details]
IMG_0279.MOV
(Reporter)

Updated

5 years ago
Whiteboard: burirun2
triage: koi+ broken feature
blocking-b2g: koi? → koi+
(Assignee)

Updated

5 years ago
Assignee: nobody → fernando.campo

Updated

5 years ago
Target Milestone: --- → 1.3 Sprint 4 - 11/8

Updated

5 years ago
Target Milestone: 1.3 Sprint 4 - 11/8 → 1.2 C4(Nov8)
(Assignee)

Comment 8

5 years ago
This is not happening on master, so my guess is that it's a matter of a not uplifted bug. Investigating right now.
(Assignee)

Comment 9

5 years ago
After further investigations and tests, I think that this is related to bug 910188, which hasn't been uplifted to 1.2 yet.
Depends on: 910188
I just retested this and it no longer reproduces after bug 910188 was uplifted.  I am going to go ahead and mark as a dupe.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910188
You need to log in before you can comment on or make changes to this bug.