two new instances like vcssync{1,2}, puppetized

RESOLVED WONTFIX

Status

Release Engineering
Tools
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: aki, Assigned: hwine)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I don't need these right away, and aiui we still have work to do to puppetize these boxes, so I thought I'd file a bug for vcssync{3,4} before I need them.

l10n and hg.m.o/build/ repos could switch over soonish, if I get these boxes, or we could move the gecko-dev/gecko-projects jobs over to puppet-managed boxen or whatever.
I've disabled puppet on vcssync{1,2}, revoked their certs, removed them from moco-nodes.pp, and added notes to their motd's.
(Reporter)

Comment 2

3 years ago
bug 924716 has details on the previous setup.
Found in triage. Dep bug#924716 is fixed. 

Whats left to do here?
Flags: needinfo?(dustin)
Flags: needinfo?(aki)
(Reporter)

Comment 4

3 years ago
Everything.  Nothing has been done.
Flags: needinfo?(aki)
Flags: needinfo?(dustin)
(Reporter)

Updated

3 years ago
Blocks: 799719
(Assignee)

Updated

3 years ago
QA Contact: john+bugzilla

Comment 5

3 years ago
Aki: does this need to be linked more directly with Pete's work on the new vcssync dependency-wise?
Component: Other → Tools
Flags: needinfo?(aki)
QA Contact: hwine
(Reporter)

Comment 6

3 years ago
Coop: this blocks bug 799719, which is assigned to Pete.  What dependency changes did you want to make?
Also not sure if we should dup 847651 against this bug.
Flags: needinfo?(aki)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 847651
"HAND-BUILT - to be rebuilt with puppet in bug 927199"
  y u make squirrels cry??
(in other words, ping?)
Assignee: nobody → pmoore
I'm on build duty next week, and have some other work stacked up - but "taking" this bug so I don't lose track that I want to do it. Hopefully sometime in August.

Updated

3 years ago
Assignee: pmoore → bugspam.Callek
Braindumped with Callek over vidyo here: https://releng.etherpad.mozilla.org/vcs-sync-puppetizing
Updated braindump with:

~/.gitconfig
~/.passwords
Also some key entries needed in ~vcs2vcs/.ssh/known_hosts!

For example:

git.mozilla.org,63.245.215.69 ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAwwdyRY+XDBzVy/XBwdlgu3cD7JZGWJZ+Mxgq3+sgZCigb9Dkpg1rgf9II8EntDdvC086GMWKqL2aVVQ79fTaze5ENaxTOl3Qhlcvj3GigFm+yRaLWXwtYz8+mVNCKADi76UzUU/8viQBZnZGZ0K48W3w71msRSHu0q7b4aBkkqMonO+czFpt+4Bjx5eZ/kTb/dAuJdNxLwrUEHkEHL/fSioOn26DZtLXp3mgzG+UtRcefxkRWuwDABP2hSXGQeoLkLe0xTYrsXySA6+81aW3CI7JtFLeVSnKqJ4HTLVQL/6ZqqcIvQrnmRSoKWGPAKx/xvUNpINrlzmIXqwQTY66yQ==

You might want to aggregate them all across the various vcs sync machines...
And there are some private keys too in ~/.ssh used for pushing to git repos (both a key for github repos, and a key for git.mozilla.org repos)
Blocks: 1054050
See Also: → bug 1112262
See bug 1112262 above - we need plenty of inodes when setting up the disk partitions...
At this point, these should be set up in AWS, not onsite.  I don't know if that affects the inode question.
Hal says dev services are taking over vcs-sync.
Assignee: bugspam.Callek → hwine
(Assignee)

Comment 17

2 years ago
dev services is handling in other bugs, no puppet involved.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.