Missing option to remove a "top site"

RESOLVED DUPLICATE of bug 913457

Status

()

Firefox for Android
Awesomescreen
RESOLVED DUPLICATE of bug 913457
5 years ago
2 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(Reporter)

Description

5 years ago
The option to remove a "top site" got lost at some point.

The option just doesn'tt exists on Nightly anymore so I ended up with the Sheraton Toronto Centre hijacking page as a "top site" with no clear way to remove it.

Steps:
- Launch Nightly
- Long press a "top site" thumbnail

Result:
There's no option to remove the thumbnail.

Expected result:
There's an option to remove the thumbnail.

Relevant bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=671131#c46
https://bugzilla.mozilla.org/show_bug.cgi?id=837132#c15

Updated

5 years ago
tracking-fennec: --- → ?
OS: Windows 7 → Android
Hardware: x86_64 → ARM
We need to decide what features we want to support:
1. Forget the site from history
2. Never show this site as a thumbnail
3. Drop the thumbnail image and make a new one when we can

Updated

5 years ago
Flags: needinfo?(ibarlow)

Updated

5 years ago
Blocks: 931021
Agree with Mark here. You can also refer to bug 931021 for more details on what "Remove" should do: 

* Removes item from Top Sites, History and Reading List. 
* If the page is also a bookmark, the bookmark is removed.
* If the page is revisited after it has been removed, it will appear in History. If it is visited enough, it will eventually appear in the Top Sites panel as well. The page will *not*, however, appear as a thumbnail again unless it is manually added by the user.
Flags: needinfo?(ibarlow)

Updated

5 years ago
tracking-fennec: ? → -

Comment 3

5 years ago
I'm going to work on fixing this issue in bug 913457.
No longer blocks: 931021
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913457
You need to log in before you can comment on or make changes to this bug.