Greek letter "κ" looks like English letter 'k' at gaia in FiraSans and FiraMono font families

VERIFIED FIXED in Firefox 28, Firefox OS v1.2

Status

--
major
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: fredy, Assigned: jfkthame)

Tracking

({regression})

unspecified
1.3 Sprint 5 - 11/22
regression

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 wontfix, firefox27 wontfix, firefox28 verified, b2g-v1.2 verified)

Details

(Whiteboard: LocRun1.2)

Attachments

(4 attachments, 2 obsolete attachments)

In Greek alphabet lowercase letter "κ" is different from English alphabet lowercase letter "k".

In FiraSans and FiraMono font families greek "κ" looks like english "k" and this looks very strange for Greek people.

You can check the difference at the next two screenshots, take a look at the music app name:

screenshot gaia v1.1 with the right music app name:
http://i.imgur.com/pCatgTr.png

screenshot gaia v1.2 with the wrong music app name:
http://i.imgur.com/ADgzpfw.png

Comment 1

5 years ago
Johnathan, Mike?
(Assignee)

Comment 2

5 years ago
Hmm, that's curious. The lowercase kappa is not simply a copy of the lowercase Latin 'k' glyph; it's got a slight "twist" to the top of the ascender and the end of the downward leg, and the upward-sloping arm has a different ending. So it appears to be a deliberate design, not just an accidental duplicate of 'k'.

Still, I agree that the tall ascender makes it look quite odd within Greek text, and I wonder whether the designers had any input into this from actual Greek users, or whether it was more of a "designer's whim".

cc'ing Patryk - can you find out if Erik has anything to say about this one?
Thanks Jonathan, for the reply. I would like to point out that this is only one of the issues with Greek characters. (e.g. σ, τ and β are totally outside Greek norms, to the point they look like an error)

We (as Greek native speakers) can provide feedback on the whole charset asap. Let me know how we can proceed. Thanks

Updated

5 years ago
Flags: needinfo?(padamczyk)
(Assignee)

Comment 4

5 years ago
(In reply to Pierros Papadeas [:pierros] from comment #3)
> Thanks Jonathan, for the reply. I would like to point out that this is only
> one of the issues with Greek characters. (e.g. σ, τ and β are totally
> outside Greek norms, to the point they look like an error)

Hmm - the beta, in particular, seems unacceptable; it looks like a variant design that might have been appropriate for U+03D0 GREEK BETA SYMBOL ("curled beta"), but it's quite unexpected for the default letter.

The sigma and tau seem to be within the general range of shapes found in other "modern" sans-serif faces, though they may not be to everyone's taste.

> We (as Greek native speakers) can provide feedback on the whole charset
> asap. Let me know how we can proceed. Thanks

Patryk, how should we address these concerns? ISTM that the kappa and beta, at least, really need to be revised before we consider this ready to ship.
In my opinion, this font is not ready to be used as the default/use-for-everything sans fonts in the phone. From my testing with gaia 1.2, the Fira fonts, apart from UI, is also being used for general web content in the browser. This could cause potential problems with website layouts?

As for the glyphs design, the issues that stand out in my eyes as a native speaker are:
- The extended upper ascender in "κ" is out of the norm. The same extended upper ascender exists in "ψ" also, but it doesn't strike same level of odd as "κ". But if it is removed from "κ", maybe it should be removed from "ψ" for consistency.
- In "στ" the upper horizontal lines between the chars don't line up
- The accent is very prominent in the character
Created attachment 820527 [details]
Large Example

I pinged Erik's team to comment.
Pierros can you provide me with a list of what falls outside of the norms within the greek character set?
Flags: needinfo?(padamczyk) → needinfo?(pierros)
Created attachment 821002 [details]
greek.png
Attachment #820527 - Attachment is obsolete: true
Hey Partyk,

Would you like me to annotate the attachment you uploaded? Can you upload all characters? (and capital)
Flags: needinfo?(pierros)
Created attachment 821080 [details]
Fira vs other fonts

Comparison between our font and the rest.
Overall here are the issues to summarize:
Beta: it looks like a variant design that might have been appropriate for U+03D0 GREEK BETA SYMBOL ("curled beta")
Kappa: ascender makes it look like a latin "k"
Omicron + Tau: in other fonts the upper horizontal lines between the chars line up, ours doesn't


We may want to revisit these… but at least they look distinct and wouldn't cause great confusion, I am just pointing out the differences here.

Zeta: the top of the character tends to be flat in other fonts
xi: the top of the character tends to be flat in other fonts
Delta: the top of the character tends to be flat in other fonts
Sigma: middle stroke's ascender, it seems the middle stroke's ascender is not to everyone's taste, and is less common on OS fonts
Created attachment 821107 [details]
Fira vs other fonts

Comparison between our font and the rest (obsoleting comment 10 due to errors).
Overall here are the issues to summarize:
Beta: it looks like a variant design that might have been appropriate for U+03D0 GREEK BETA SYMBOL ("curled beta")
Kappa: ascender makes it look like a latin "k"
Sigma + Tau: in other fonts the upper horizontal lines between the chars line up, ours doesn't


We may want to revisit these… but at least they look distinct and wouldn't cause great confusion, I am just pointing out the differences here.

Zeta: the top of the character tends to be flat in other fonts
xi: the top of the character tends to be flat in other fonts
Delta: the top of the character tends to be flat in other fonts
Psi: middle stroke's ascender, it seems the middle stroke's ascender is not to everyone's taste, and is less common on OS fonts
Attachment #821080 - Attachment is obsolete: true
I think it's mostly the kappa, psi and iota that look out of place. Kappa seems plain wrong, due to the similarity to the latin 'k'. Psi is presumably following the same pattern as kappa, so if the latter is changed, I don't think it makes much sense to leave the former as it is. Iota is not wrong per se, but it seems like it was copied verbatim from a different font (courier?). It doesn't fit nice with the rest IMHO.

I find the rest of the mentioned characters OK, they actually remind me of the font used in elementary school books. It looks like the designer went for a playful mood, which sounds in line with our branding. I only wonder if the slight curvature in the upper right hurts the legibility of sigma and tau. They look OK in the big screen of my Nexus S, but I'm not sure how our more common HVGA screens would treat them.
Just confirming what Panos said, the problematic characters are:

kappa (κ): for the pointy first stroke
giota (ι): for the left pointing stroke
Sigma + Tau (σ + τ): for the upper stroke that shouldn't be curly at the end
psi: should change for consistency with kappa

beta, delta and others are OK as this is the general direction of the font.

What are next steps?
(Reporter)

Updated

5 years ago
blocking-b2g: --- → koi?
Flags: needinfo?(padamczyk)
We have agreement from Erik Spiekermann's group to fix these issues (comment 13)... this will likely get fixed in for v.1.3 or v.1.4 since we'll need to roll this in with some other changes like open sourcing the font.
Flags: needinfo?(padamczyk)
Assignee: nobody → padamczyk
I understand that there is pressure, but I will insist at least fixing "κ" problem in v1.2.

The last three days I've been testing the greek l10n on this version and this bug is very confusing and annoying. :(

I am afraid that this will be also a blocker for the greek career partner in accepting v1.2 update.
Delphine,

Please advice if this is a cert blocker or not?
Flags: needinfo?(community)

Comment 17

5 years ago
That'd be a question for a TAM, I think.

Also, community@localization.bugs is an alias, not an individual that you can needinfo reliably.
Flags: needinfo?(community)

Updated

5 years ago
Keywords: regression, regressionwindow-wanted

Comment 18

5 years ago
No regression window necessary. We know what's broken.
Keywords: regressionwindow-wanted
(In reply to Michael Wu [:mwu] from comment #18)
> No regression window necessary. We know what's broken.

Well right - but we were trying to find out in triage what patch caused this. Specifically, we were trying to see if this is a fallout from bug 897009.
Whiteboard: LocRun1.2

Updated

5 years ago
Blocks: 897009
Backout isn't possible here because we had no Greek character support before this new font and we want Greek for 1.2.
blocking-b2g: koi? → koi+
(In reply to Andrew Overholt [:overholt] from comment #21)
> Backout isn't possible here because we had no Greek character support before
> this new font and we want Greek for 1.2.

Hey Andrew,

I have tested Greek l10n on v1.1 devices and Greek characters are fine. Also v1.1 is the version that local carrier has launched today and support Greek l10n.

Do I miss something?

Comment 23

5 years ago
On 1.1, Roboto is used for Greek.
Yeah, we have a new font with Greek characters in 1.2.
Patryk , I see the following options :

a) Fallback to roboto for everything ?
b) Fallback to roboto only for the letters that are problematic
c) replace the font files for the problematic letters to Roboto ?

Anything I missed keeping in mind the 1.2 timelines, please let me know what you think of any of the above approach or are we planning on any forward fixes here ?
Flags: needinfo?(padamczyk)
(Assignee)

Comment 26

5 years ago
We could change the default font-family for Greek from Fira to Roboto, but users would still see the Fira glyphs in some cases, depending on CSS styling (which may explicitly call for Fira) and/or page language settings.

Patryk, can we get updated fonts with the Greek fixes from edenspiekermann in time for 1.2 (without necessarily addressing the open-source process/format issues yet)? I'm not at all clear on how the b2g timelines work.

If we can't get updated fonts from the designers in time, should we attempt to patch the lowercase kappa locally? (I could probably do that without touching anything else in the fonts.) That's the most glaring issue here; various other glyphs may be questionable, but we're not in a position to make extensive revisions in a hurry.
Looks like the update won't happen till v.1.3.
Reverting back to ROBOTO is really not an option, it impacts too many things like localization (spacing / layout) and marketing.

I see 2 potential options.
1. [preferred] When the user chooses GREEK, we switch out the font to whatever it was in v.1.1, ROBOTO?
2. Jonathan Kew updates that current Fira fonts with with a corrected lowercase kappa. Time allowing.

The issue here is stylistic... are the Greek carriers taking v.1.2? Is this really a gating issue from them?
When do we need to make the change by?
Flags: needinfo?(padamczyk)
(In reply to Patryk Adamczyk [:patryk] UX from comment #27)
> I see 2 potential options.
> 1. [preferred] When the user chooses GREEK, we switch out the font to
> whatever it was in v.1.1, ROBOTO?
> 2. Jonathan Kew updates that current Fira fonts with with a corrected
> lowercase kappa. Time allowing.

Hey Patryk,

The first option seems to be the appropriate one, but it should be followed asap in order to test greek l10n with this font and fix potential bugs. Changes on l10n can be done until Monday (25 Nov) according to https://etherpad.mozilla.org/schedules-b2g-onedottwo

The second option also fix the main problem (lowercase kappa) and probably can go after Monday.

> 
> The issue here is stylistic... are the Greek carriers taking v.1.2? Is this
> really a gating issue from them?

I don't know if the Greek carrier has raised this issue in their communication channel but I can contact them to do so. However this will bring more delay in an issue that I can assure you that would be 100% a blocker.

If I get right what you define as a stylistic issue, then the lowercase kappa is not one. It is a wrong letter issue, the latin k (even if it is slightly different is interpreted as latin k) in place of greek κ.

In other words, there isn't a greek font, even among the greek calligraphic ones, that has a letter like latin k and if there are one or two that have this latin k letter, no one that use greek alphabet would choose them.
So if ONLY for the greek language... (user selects greek from the language choices) we switch back to Roboto, that should be okay. We'll need to make sure we include the following versions of Roboto
Light, Regular, Medium, Bold in both regular and italic styles.

We'll have a proper fix for v.1.3.
Does the font switch happen only if one uses a localized version? What about those (like me) who use an English locale, but often visit sites in Greek? Do we still display the ugly font?
(In reply to Panos Astithas [:past] from comment #30)
> Does the font switch happen only if one uses a localized version? What about
> those (like me) who use an English locale, but often visit sites in Greek?
> Do we still display the ugly font?

Yes this switch will affect sites in Greek, but you will agree that is much preferable an "ugly" font than a "broken" one.
(In reply to Patryk Adamczyk [:patryk] UX from comment #29)
> So if ONLY for the greek language... (user selects greek from the language
> choices) we switch back to Roboto, that should be okay. We'll need to make
> sure we include the following versions of Roboto
> Light, Regular, Medium, Bold in both regular and italic styles.
Looks like we have agreed on an option here.Thanks ! How much effort would this be and so we have the right owner on this bug? Just to confirm this is the lowest risk option we have given the time remaining to resolving 1.2 issues ?
> 
> We'll have a proper fix for v.1.3.
(In reply to bhavana bajaj [:bajaj] from comment #32)
> (In reply to Patryk Adamczyk [:patryk] UX from comment #29)
> > So if ONLY for the greek language... (user selects greek from the language
> > choices) we switch back to Roboto, that should be okay. We'll need to make
> > sure we include the following versions of Roboto
> > Light, Regular, Medium, Bold in both regular and italic styles.
> Looks like we have agreed on an option here.Thanks ! How much effort would
> this be and so we have the right owner on this bug? Just to confirm this is
> the lowest risk option we have given the time remaining to resolving 1.2
> issues ?
> > 
> > We'll have a proper fix for v.1.3.

Can we get a new bug on file in that case and set to 1.3? with the proposed path to resolve the issue.Thanks !
(Assignee)

Comment 34

5 years ago
(In reply to Patryk Adamczyk [:patryk] UX from comment #29)
> So if ONLY for the greek language... (user selects greek from the language
> choices) we switch back to Roboto, that should be okay. We'll need to make
> sure we include the following versions of Roboto
> Light, Regular, Medium, Bold in both regular and italic styles.

Actually, it's occurred to me that there's a better way we can do this. Provided we make sure the Roboto faces are present to act as a fallback,[1] we can simply drop the Greek letters from the Fira fonts completely. That's a trivial change - much simpler than *modifying* any glyphs.

That way Roboto will be used for Greek text everywhere, whether in the UI or on websites, regardless of the locale/language choices.

I'll go ahead and prepare a patch that strips out the Greek from Fira, so we can test the resulting behavior.


[1] Looks like they are there already; see https://github.com/mozilla-b2g/moztt/commit/61281cb89364d9132cfe3c50c5ebe4fcf9bb1f07.
(Assignee)

Comment 35

5 years ago
Created attachment 8334425 [details] [review]
PR to update the Fira OT fonts in moztt, removing the Greek range

This simply removes the Greek characters from the 'cmap' tables of all the Fira OT fonts, so that we'll no longer use them; nothing else is modified within the font files.

(In addition, we should update the default Greek font prefs appropriately, so they don't even try to use Fira as first choice.)
Attachment #8334425 - Flags: review?(mwu)
(Assignee)

Comment 36

5 years ago
Created attachment 8334426 [details] [diff] [review]
use Roboto / Droid Sans Mono for Greek, until Fira glyphs are revised
Attachment #8334426 - Flags: review?(mwu)
(Assignee)

Updated

5 years ago
Assignee: padamczyk → jfkthame
(Assignee)

Comment 37

5 years ago
Patryk, I tagged :mwu for review here as he seems to have been doing most of the font updates, but if you're a more appropriate reviewer, please feel free to take over!
:mwu is the best person for the technical implementation of the font in the OS.

Updated

5 years ago
Attachment #8334426 - Flags: review?(mwu) → review+

Comment 39

5 years ago
BTW I'm not sure if we have Droid Mono installed by default anymore. We might need to add Droid Mono back into the list at https://github.com/mozilla-b2g/moztt/blob/master/fonts.mk#L18 .
(Assignee)

Comment 40

5 years ago
My build seems to have it at out/target/product/unagi/system/fonts/DroidSansMono.ttf. I see it's listed in frameworks/base/data/fonts/fonts.mk; is that sufficient?

Comment 41

5 years ago
We usually don't load frameworks/base/data/fonts/fonts.mk - external/moztt/fonts.mk is suppose to be loaded instead. Try deleting out/target/product/unagi/system/fonts/DroidSansMono.ttf and see if it comes back. If it does, we might not need to do anything.

Comment 42

5 years ago
Comment on attachment 8334425 [details] [review]
PR to update the Fira OT fonts in moztt, removing the Greek range

Rubber stamping and assuming this does what it says on the label.
Attachment #8334425 - Flags: review?(mwu) → review+
See Also: → bug 940397
(Assignee)

Comment 43

5 years ago
(In reply to Michael Wu [:mwu] from comment #41)
> We usually don't load frameworks/base/data/fonts/fonts.mk -
> external/moztt/fonts.mk is suppose to be loaded instead. Try deleting
> out/target/product/unagi/system/fonts/DroidSansMono.ttf and see if it comes
> back. If it does, we might not need to do anything.

Ah, you're right, that must have been a stale file, and I hadn't clobbered that build any time recently.

I updated the PR to add it to external/moztt/fonts.mk. Will you take care of merging that? (I don't believe I have the necessary permissions - or the github confidence/knowledge!)
(Assignee)

Comment 45

5 years ago
Pushed the default-prefs change to inbound for mozilla-central:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cd98cb3c52df

What other branch(es) do we need this on?

Comment 46

5 years ago
We'll also need it on http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/ , though RyanVM and other sheriffs usually take care of that.
https://hg.mozilla.org/mozilla-central/rev/cd98cb3c52df
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-b2g-v1.2: --- → affected
https://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/9fa509ce29d2
status-b2g-v1.2: affected → fixed
status-firefox26: --- → wontfix
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(Reporter)

Updated

5 years ago
Status: RESOLVED → VERIFIED
The letter 'κ' in Greek now shows the correct 'κ' and no longer shows the English 'K' in the latest Buri 1.2 and Master 1.3 build.

1.2 Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131205004003
Gaia: 0659f16b9790b1cf9eba4d80743fcc774d2ffe3a
Gecko: af2c7ebb5967
Platform Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_20131115

1.3 Environmental Variables:
Device: Buri v1.3 MOZ RIL
BuildID: 20131205040201
Gaia: 1dd0e5c644b4c677a4e8fa02e50d52136db489d9
Gecko: 725c36b5de1a
Version: 28.0a1
Firmware Version: V1.2_20131115

Updated

5 years ago
status-b2g-v1.2: fixed → verified
status-firefox28: fixed → verified
(Reporter)

Updated

4 years ago
See Also: → bug 1010529
You need to log in before you can comment on or make changes to this bug.