[Flatfish][System] Make system dialogs not fill full screen

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gasolin@mozilla.com, Assigned: gasolin@mozilla.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

5 years ago
Make system dialogs not fill full screen, have modal dialog instead
(Assignee)

Updated

5 years ago
Blocks: 903304
(Assignee)

Updated

5 years ago
Assignee: nobody → gasolin
(Assignee)

Comment 1

5 years ago
Created attachment 820122 [details]
alert
(Assignee)

Comment 2

5 years ago
Created attachment 820123 [details]
confirm
(Assignee)

Comment 3

5 years ago
Created attachment 820125 [details]
prompt
(Assignee)

Comment 4

5 years ago
Created attachment 820131 [details]
pull request redirect to github

change based on gaia-local modifications https://github.com/gaia-local/gaia/pull/76/files
Attachment #820131 - Flags: review?(alive)
Comment on attachment 820131 [details]
pull request redirect to github

CSS only and Tablet only change r=me
Attachment #820131 - Flags: review?(alive) → review+
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

5 years ago
Comment on attachment 820131 [details]
pull request redirect to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] CSS only and Tablet only change
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: tablet only
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]:
Attachment #820131 - Flags: approval-gaia-v1.2?
(Assignee)

Comment 8

5 years ago
Comment on attachment 820131 [details]
pull request redirect to github

Draw back the v1.2 approval since there's still some dialogs need to be updated.
Its better to have them all in a release version, which we could not commit it will happens in v1.2.

It might be better to let vendor decide if they want cherry-pick this to v1.2
Attachment #820131 - Flags: approval-gaia-v1.2?
(Assignee)

Updated

5 years ago
Blocks: 935816
You need to log in before you can comment on or make changes to this bug.