Closed Bug 928379 Opened 6 years ago Closed 3 years ago

QuickTime controls bar is missing

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(firefox24 wontfix, firefox25 affected, firefox26 affected, firefox27 affected, firefox38 affected)

RESOLVED WORKSFORME
Tracking Status
firefox24 --- wontfix
firefox25 --- affected
firefox26 --- affected
firefox27 --- affected
firefox38 --- affected

People

(Reporter: simona.marcu, Unassigned)

References

()

Details

(Whiteboard: [needstriage])

Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20131017174213
QuickTime version: 7.7.4

Steps to reproduce:
1. Navigate to http://trailers.apple.com/trailers/ and select one trailer of your choice.
2. Click on the play button.
3. Hover the mouse over the video content.

Expected results:
The controls bar is displayed.

Actual results: 
The controls bar is missing.

Notes:
Reproducible with: Firefox 24, Firefox 25 beta the latest Nightly 27.0a1 and the latest Aurora 26.0a2.
Reproducible also with QuickTime 7.6 and 7.5.5.
Not reproducible on Chrome 30.0.1599.101 m.
Reproducible on Opera 12.16.
The issue is not reproducible on Mac OS X.
Reproducible on Windows 7.
Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0

Reproducible with Firefox 25 beta 9 on Ubuntu 13.04 64bit with mplayer and Quicktime 7.6.6. plugins installed.
Please find a regression window ASAP.
OS: Windows XP → All
Hardware: x86 → All
I can also reproduce in Firefox4.0 on windows7 and ubuntu12.04.
So, I think this is not a recent regression.
Giving this a quick look in Nightly i'm not sure about what exactly is happening here.

However, i noticed that when having the dev tools inspector open you see the controls and not the video (just black) and when closing the inspector the video can be seen but not the controls.
The controls are not from the plugin, they are HTML elements. They have the controls wrapped in a div that is a sibling in the DOM tree to the Quicktime <object>.

So... either this is a simple site-issue with e.g. z-index or other layering issues, or somehow event delivery or focusing does work differently here than in other browsers.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

I can also reproduce this issue with Firefox 4.0 on Windows 7, and like I mentioned in the Description of this bug - the issue is also reproducible with the latest 3 versions of QuickTime (7.7.4, 7.6 and 7.5). This is not a regression since it used to work fine before.
Moving to Tech Evangelism for the comment 5 et al.
Assignee: nobody → english-us
Component: Plug-ins → English US
Product: Core → Tech Evangelism
Version: 25 Branch → Trunk
Duplicate of this bug: 965614
I've been experiencing this issue for awhile now, and can confirm that I'm still experiencing it in Firefox 27.0.1
(In reply to jdorenbush from comment #8)
> I've been experiencing this issue for awhile now, and can confirm that I'm
> still experiencing it in Firefox 27.0.1

Yup, this is not a Firefox bug. It's either a bug in Quicktime or in http://trailers.apple.com/trailers/, either way it's Apple's bug to fix.
I've just send a bug report to trailers@mac.com as well as the support team and asked for feedback from them.
Has there been any progress on resolving this? @culicidae have you received a response from trailers@mac.com?
This has been fixed. I guess, because I have no issues with Trailers on Apple.com
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 5 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Hasn't been fixed for me. I still don't have any video controls.
(In reply to jdorenbush from comment #13)
> Hasn't been fixed for me. I still don't have any video controls.

This works fine for me in Firefox 32 & Nightly with Quicktime 7.7.3 - can you provide more details and check that you're on the latest versions?
(In reply to Georg Fritzsche [:gfritzsche] from comment #14)
> (In reply to jdorenbush from comment #13)
> > Hasn't been fixed for me. I still don't have any video controls.
> 
> This works fine for me in Firefox 32 & Nightly with Quicktime 7.7.3 - can
> you provide more details and check that you're on the latest versions?

Mozilla Firefox 32.0
QuickTime Plug-in 7.6.6

Let me know if you need anything else, thanks.
(In reply to jdorenbush from comment #15)
> QuickTime Plug-in 7.6.6

That looks outdated - can you try updating to the latest version?
https://www.apple.com/quicktime/download/

> QuickTime is built into Mac OS X.
> Use Software Update to keep QuickTime up to date on your Mac.
> Previous versions of QuickTime are also available from Apple Support.

http://support.apple.com/downloads/#quicktime for people without MacOSX
I'm on Ubuntu (Linux) and I'm not sure how to update QuickTime on here. Any suggestions?
Ah I had forgotten about that. Apple doesn't like very much Linux. hmmm :/
I was trying to find answers, found this old page which doesn't help either.
http://askubuntu.com/questions/1695/watch-quicktime-videos-in-the-browser

I was tempted to REOPEN and sees if the site is not playing bad with Linux users, but faking my UA to be Firefox Linux Ubuntu, I still get Quicktime working.

I wonder if on Ubuntu forums, you can find the Quicktime + Ubuntu answer. 

Does it work in other browsers running on Ubuntu?
(In reply to Karl Dubost :karlcow from comment #19)
> Ah I had forgotten about that. Apple doesn't like very much Linux. hmmm :/
> I was trying to find answers, found this old page which doesn't help either.
> http://askubuntu.com/questions/1695/watch-quicktime-videos-in-the-browser
> 
> I was tempted to REOPEN and sees if the site is not playing bad with Linux
> users, but faking my UA to be Firefox Linux Ubuntu, I still get Quicktime
> working.
> 
> I wonder if on Ubuntu forums, you can find the Quicktime + Ubuntu answer. 
> 
> Does it work in other browsers running on Ubuntu?

I tried to test in Chrome but I can't even get the Quicktime plugin to work in Chrome.
Still seen on Ubuntu 14.04 x86 using Firefox 38 Beta 8 (QuickTime 7.6.6).
Re-opened this bug based on comment 21.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Florin,
Where do we stand on that? Is it still broken on Linux?
Flags: needinfo?(florin.mezei)
Whiteboard: [needstriage]
QuickTime does not exist on Linux! You are probably using some other plugin which is like quicktime.

But in any case, we aren't going to fix this. It's just not important.
Status: REOPENED → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(florin.mezei)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.