Games icon has grey line above it on Marketplace in Games category

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: davidwboswell, Unassigned)

Tracking

Avenir
ARM
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: [dogfood])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Phone:
Alcatel One Touch

Firefox OS Version:
1.1.0.0-prerelease

Issue Details:
When checking out the Marketplace on my phone, I'm noticing a thin grey line above the games icon in the Games category.  I'm not seeing the same thing with the icons in the other categories and I'm not seeing it on the desktop version of the Marketplace in the Games section.

Associated App:
Marketplace
(Reporter)

Comment 1

5 years ago
Created attachment 819244 [details]
Screenshot of Games section showing the games icon with the grey line

Updated

5 years ago
Component: DogfoodTriage → Consumer Pages
Product: Boot2Gecko → Marketplace
Version: unspecified → Avenir

Comment 2

5 years ago
I've tried to reproduce this in the following places:

FX Nightly, w/responsive
FXOS simulator 1.1.0.0-prerelease
Chrome Canary (because why not)

I can't reproduce it anywhere. It looks to me like this is a gecko/SVG bug (the icon is a sprited and scaled SVG).

My best stab at fixing this bug is to decrease the precision of all of the floating point numbers in the sprite:

https://github.com/mozilla/fireplace/commit/9dfee8b1f8c4b356c937f187aeef5cf98b150752

That's about as good as we can do for now. I'd bet the issue is fixed in B2G 1.2, so keep your eyes peeled. Thanks!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.