awesomescreen remains visible across multiple tabs on tablet

RESOLVED FIXED in Firefox 28

Status

()

Firefox for Android
Awesomescreen
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: mcomella, Assigned: lucasr)

Tracking

26 Branch
Firefox 28
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 fixed)

Details

(Reporter)

Description

4 years ago
1) Open two tabs with web content
2) Click the url bar to open the awesomescreen
3) Open the tabs tray
4) Select the other open tab

Expected: The selected tab's web content is shown
Actual: The awesomescreen remains open

Updated

4 years ago
status-firefox26: --- → affected
status-firefox27: --- → affected
tracking-firefox26: --- → ?
tracking-firefox27: --- → ?
The correct behavior should probably be to leave the about:home screen when we open the tabs tray.
(Reporter)

Updated

4 years ago
Blocks: 928593
(Reporter)

Updated

4 years ago
No longer blocks: 917394
(Reporter)

Comment 2

4 years ago
The behavior in comment 1 seems like the quickest and cleanest solution.

Alternatively, users may want to edit their current tab from the awesomescreen with the tabs tray open, however, selecting content from the awesomescreen (including the toolbar) closes the tabs tray, so that interaction paradigm is more or less pointless at the present.

Ian, what do you think?

(Side note: The discussion here may be applicable to the discussion in bug 917514)
Flags: needinfo?(ibarlow)

Comment 3

4 years ago
 I can reproduce this bug in today's nightly build using a Galaxy 10'1 Tab and Android 3.1
(Assignee)

Comment 4

4 years ago
This will also be fixed by bug 918007. We'll disable all toolbar elements while editing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 5

4 years ago
I closed as WONTFIX just to make sure that no one would work on this before bug 918007 is fixed. But maybe adding a dependency is a better way to handle this.
Status: RESOLVED → REOPENED
Depends on: 918007
Resolution: WONTFIX → ---
Tracking this for 918007
tracking-firefox26: ? → +
tracking-firefox27: ? → +
(In reply to Michael Comella (:mcomella) from comment #2)
> The behavior in comment 1 seems like the quickest and cleanest solution.
> 
> Alternatively, users may want to edit their current tab from the
> awesomescreen with the tabs tray open, however, selecting content from the
> awesomescreen (including the toolbar) closes the tabs tray, so that
> interaction paradigm is more or less pointless at the present.
> 
> Ian, what do you think?
> 
> (Side note: The discussion here may be applicable to the discussion in bug
> 917514)

un-needinfoing due to bug 918007
Flags: needinfo?(ibarlow)

Updated

4 years ago
Status: REOPENED → NEW
(Assignee)

Comment 8

4 years ago
The patches for bug 918007 have landed in Nightly. You cannot open the tabs tray while editing anymore. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago4 years ago
status-firefox28: --- → fixed
Resolution: --- → FIXED
Assignee: nobody → lucasr.at.mozilla
Target Milestone: --- → Firefox 28
status-firefox26: affected → ---
status-firefox27: affected → ---
tracking-firefox26: + → ---
tracking-firefox27: + → ---
You need to log in before you can comment on or make changes to this bug.