Standard folders, menus, buttons , etc. not translated to locale, and session state lost, after TB update from Ubuntu.

UNCONFIRMED
Unassigned

Status

Thunderbird
Folder and Message Lists
UNCONFIRMED
4 years ago
2 months ago

People

(Reporter: Ulf Zibis, Unassigned, NeedInfo)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
str
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911164256

Steps to reproduce:

Hi,
I use my Mozilla profiles interchangeably from Windows 7 and Ubuntu, see: http://kb.mozillazine.org/Sharing_a_profile_between_Windows_and_Linux 
Windows: version 24.0.1
Ubuntu:   version 24.0.0 (update is still not available via package manager)



Actual results:

When I switch from Windows to Ubuntu, I first have to acknowledge a new Add-on check and then I see "Inbox" "Drafts" etc.
(On 2nd start on Ubuntu I correctly see "Posteingang" "Entwürfe" etc.)


Expected results:

- TB should display the german "Posteingang" "Entwürfe" etc.
- Ubuntu 12.04 LTS should update to TB 24.0.1.
(Reporter)

Updated

4 years ago
See Also: → bug 91866
(Reporter)

Updated

4 years ago
See Also: → bug 888371

Comment 1

4 years ago
Please check if the files in the Local directory (see account settings) representing the special folders (Inbox, Drafts, etc.) are with proper uppercased names (Inbox, not inbox). Or you may try to change the case whether it affects something.
(Reporter)

Comment 2

4 years ago
Yes, the files and folders are all proper uppercased names.
(Reporter)

Comment 3

4 years ago
After Update of TB from 24.1.1 to 24.2.0, on Ubuntu only, I experienced the same Problem without Windows involved:
Standard folders and all menus, buttons etc, except those from Addons, were in English instead German.
This time, after restart TB again appears in English. :-(
So changing the subject.
Summary: Inbox etc. not translated to locale after switch to Ubuntu → Standard folders, all menus, buttons etc, except those from Addons, not translated to locale at first startat Ubuntu after Update or switch from Windows

Comment 4

3 years ago
Is this dependent on bug 888371?
Flags: needinfo?(Ulf.Zibis)

Comment 5

3 years ago
The same issue with Gentoo's native build. Monitoring since 17 ESR.
See downstream bug https://bugs.gentoo.org/show_bug.cgi?id=459432

So, issue looks to be not Ubuntu-specific, but more common.

Comment 6

3 years ago
Update in 38.x.z ESR branch.
This bug seems to be fixed. Waiting nect update to confirm it.

Comment 7

3 years ago
> Update in 38.x.z ESR branch. This bug seems to be fixed. 

Do you have a URL for a bug report or forum post that has more detail about this being fixed?
Flags: needinfo?(Ikonta)
(Reporter)

Comment 8

3 years ago
The problem is still alive.
Every time, TB indicates a version change, at first start, language support is disabled, the session state is lost, and must be repaired manually - i.e. - enable the languages and recover session.json from a backup.
It doesn't matter, if the version change is mocked by the switch from Windows or is real from official update. Last seen at update from 31.x.x to 38.2.0 at Ubuntu.
Flags: needinfo?(Ulf.Zibis)
(Reporter)

Comment 9

2 years ago
New observation:
Since some weeks, I have set the Offline settings to: "ask user, if to start online"
After TB update, here from 38.2.0 to 38.3.0, I first see this dialogue in the expected local language and after "start online", anything disappears from the screen and after some seconds I'm asked again - this time in english, if I want to start in online state.
Maybe this additional info helps to find the source of the problem.
Summary: Standard folders, all menus, buttons etc, except those from Addons, not translated to locale at first startat Ubuntu after Update or switch from Windows → Standard folders, all menus, buttons etc, except those from Addons, not translated to locale and session state lost at first start at Ubuntu after Update or switch from Windows

Comment 10

2 years ago
(guess we are not going to hear from Ikonta)
Flags: needinfo?(Ikonta)

Comment 11

2 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #7)
> > Update in 38.x.z ESR branch. This bug seems to be fixed. 
> 
> Do you have a URL for a bug report or forum post that has more detail about
> this being fixed?

Excuse me for long response, for rather long I had no time to update my system.

I have no external url, just my experience.
This bug is my primary url for this issue.

For now I can confirm: 
After update to 38.3.0 ESR issue doesn't appeared.

But here I need to point on notable detail: in TB 38 ESR I find profile, oryginally imported from windows build, completely broken and regenerated it, getting from old one just mail archive.
If this issue is about cross-platform profile compatibility — I don't know how to debug it and what we could do.
(Reporter)

Comment 12

2 years ago
I found a possible cause for this bug: bug 1227353.
I still experience this bug regularly. I now have repaired the link manually. I will observe, if the bug still occurs.

Updated

2 years ago
See Also: → bug 1227353
Summary: Standard folders, all menus, buttons etc, except those from Addons, not translated to locale and session state lost at first start at Ubuntu after Update or switch from Windows → Standard folders, menus, buttons, etc, not translated to locale (and session state lost) at first start at Ubuntu, after Update or switch from Windows. Except those from Addons.
let's do the dup
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1227353
(Reporter)

Comment 14

4 months ago
This is not a duplicate of bug 1227353.
I have removed the confusing _CACHE_CLEAN_ symlink in my profile since long time, it never reappeared, but this bug still occurs on each update from Ubuntu repository, even there was no switch to/from Windows.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 15

4 months ago
Summary line repaired: There is no Addon where the session state was kept.
Summary: Standard folders, menus, buttons, etc, not translated to locale (and session state lost) at first start at Ubuntu, after Update or switch from Windows. Except those from Addons. → Standard folders, menus, buttons, etc. (except those from Addons) not translated to locale and session state lost at first start at Ubuntu, after Update or switch from Windows.
(Reporter)

Updated

4 months ago
Summary: Standard folders, menus, buttons, etc. (except those from Addons) not translated to locale and session state lost at first start at Ubuntu, after Update or switch from Windows. → Standard folders, menus, buttons (except those from Addons), etc. not translated to locale and session state lost after TB update from Ubuntu or switch from Windows.

Comment 16

4 months ago
(I think we don't really care about the effect of addons)
Summary: Standard folders, menus, buttons (except those from Addons), etc. not translated to locale and session state lost after TB update from Ubuntu or switch from Windows. → Standard folders, menus, buttons , etc. not translated to locale, and session state lost, after TB update from Ubuntu or switch from Windows.

Comment 17

3 months ago
(In reply to Ulf Zibis from comment #14)
> this bug still occurs on each update from
> Ubuntu repository, even there was no switch to/from Windows.

Then let's simply the summary.

This must be a rare and unusual thing, otherwise we'd have tons of problem reports about updates. 
Have you tried the mozilla install?
Does it happen if you use a new profile? 
  (create a test profile using https://support.mozilla.org/en-US/kb/using-multiple-profiles )
Flags: needinfo?(Ulf.Zibis)
Summary: Standard folders, menus, buttons , etc. not translated to locale, and session state lost, after TB update from Ubuntu or switch from Windows. → Standard folders, menus, buttons , etc. not translated to locale, and session state lost, after TB update from Ubuntu.

Comment 18

3 months ago
neander have you ever seen this?
Flags: needinfo?(neandr)

Comment 19

3 months ago
Sorry, don't use ubuntu but mozilla installations. And also not using W7 anymore (and probably the old W7 installation isn't up-to-last-release).

Current installations like this:
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0
Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Thunderbird/57.0

In the past I used one TB profile for W7 and TB (same with FX) but never had a problem. Also can't remember if it was Ubuntu or 'native' mozilla.
Flags: needinfo?(neandr)
(Reporter)

Comment 20

2 months ago
This bug also occurs partly, i.e. the session state was deleted, at normal restart after a save mode run.

I did not have tried mozilla install. (How to do this in your sense, using a .deb package, manually compile or what ever, and from which download URL?)
I did not try with a new profile.
Both seems much work to establish the correct environment.
(Reporter)

Comment 22

2 months ago
(In reply to Wayne Mery (:wsmwk) from comment #21)
> Just expand
> https://releases.mozilla.org/pub/thunderbird/releases/52.5.2/linux-x86_64/de/
> thunderbird-52.5.2.tar.bz2 and run

Where does it save it's profiles after first start, when I "install" it somewhere in /home/user folder? Does it eventually overwrite my existing profiles.ini or use the existing default profile at ~/.thunderbird?
One difference might be, that the language pack is included there in contrast to the Ubuntu installation, where the language pack is installed by an extra package.
How do I initiate an update, to do the test?
To have more than the standard session tabs, I guess, I have to at least install "ThunderBrowse" addon.

Comment 23

2 months ago
https://releases.mozilla.org/pub/thunderbird/releases/52.5.2/linux-x86_64/de/thunderbird-52.5.2.tar.bz2 would be an install, not an update

for basic details https://support.mozilla.org/en-US/kb/installing-thunderbird-linux

If ubuntu puts thunderbird data in the "mozilla standard" location then there should be no other work. For other questions and help I suggest you ask in an ubuntu forum or irc channel, or #thunderbird on irc
(Reporter)

Comment 24

2 months ago
(In reply to Wayne Mery (:wsmwk) from comment #23)
> https://releases.mozilla.org/pub/thunderbird/releases/52.5.2/linux-x86_64/de/
> thunderbird-52.5.2.tar.bz2 would be an install, not an update
Yes, I know, but for reproducing the bug I need to simulate an update. Maybe I should first install an older version, an then overwrite it with the newer version, what you think?
> for basic details
> https://support.mozilla.org/en-US/kb/installing-thunderbird-linux
> 
> If ubuntu puts thunderbird data in the "mozilla standard" location then
> there should be no other work.
You mean ~/.thunderbird as "mozilla standard"?
> For other questions and help I suggest you ask in an ubuntu forum or irc channel, or #thunderbird on irc
This is what I meant with "much work".
(Reporter)

Comment 25

2 months ago
On another machine of a friend, where I too often saw this "not translated to locale", but which is 32-Bit Ubuntu, I now updated from 52.5.0 to 52.5.2 with help of: https://launchpad.net/~mozillateam/+archive/ubuntu/ppa
This time, the bug didn't appear.

But on my own machine with 64-Bit, the same scenario reproduced the bug again.
You need to log in before you can comment on or make changes to this bug.