Closed Bug 929603 Opened 8 years ago Closed 8 years ago

[B2G][l10n][Calendar]Multiple languages have a line spacing issue when word wrap is utilized during localization on an All Day event.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.2 affected, b2g-v1.3 affected, b2g-v1.4 fixed)

VERIFIED FIXED
Tracking Status
b2g-v1.2 --- affected
b2g-v1.3 --- affected
b2g-v1.4 --- fixed

People

(Reporter: pbylenga, Assigned: flod)

References

Details

(Keywords: l12y, Whiteboard: LocRun1.2,LocRun1.3)

Attachments

(4 files)

Description:
Multiple Languages do not have enough spacing between lines when an All Day event is localized and requires word wrapping to fit the “All Day” text.  On Month tab the two lines of text are flush with each other.  On Day Tab there is a 1 pixel height of space between the lines.  Due to the amount of space in the cell user would expect more space between the 2 lines of text.

Repro Steps:
1) Updated Buri to Build ID: 20131022004000
2) Navigate to Settings and change language to Italian
3) Navigate to Homescreen and Launch Calendar App
4) Create a new All Day event and save it
5) Observe the localized text “All Day” to the left of the new event on the Month tab.
6) Observe the localized text “All Day” to the left of the new event on the Day tab.

Actual:
On the Month tab there is no spacing between the lines of text for the title and on the Day tab there is only a 1 pixel of space utilized.

Expected:
Proper spacing relative to the amount of space available.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131022004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7453a764f9a9
Gaia: 00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082 
Firmware Version: US_20131015
Notes:
Repro frequency: 5/5 100%
See attached: Screenshot
Languages that repro issue so far in v1.2
Catalan
Czech
Greek
Croatian
Hungarian
Italian
Nederlands (Dutch)
Polish
Slovak

Languages that do no repro issue so far in v1.2
English
Russian
zh-TW is also effected but without word wrap.
zh-CN is also effected but without word wrap.
Attached image AllDayEvent_zh-CN
Blocks: 928174
Keywords: l12y
Flagging UX team about this! thanks :)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Eric to advise.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(epang)
Let's update the line height to 12px, thanks!
Flags: needinfo?(epang)
Blocks: 967050
Summary: [B2G][1.2][l10n][Calendar]Multiple languages have a line spacing issue when word wrap is utilized during localization on an All Day event. → [B2G][l10n][Calendar]Multiple languages have a line spacing issue when word wrap is utilized during localization on an All Day event.
Whiteboard: LocRun1.2 → LocRun1.2,LocRun1.3
Blocks: 938423
(In reply to Peter Pin-Guang Chen [:petercpg] (MozTW.org) from comment #2)
> zh-TW is also effected but without word wrap.

Peter, can you explain me what the problem is for zh-TW? I'm looking also at the zh-CN but I can't see anything wrong.

This bug is about line-height being to small for locales where "All day" spans on two lines (see highlighted areas in the first screenshot).
Top current, bottom patched.
Attached file Pull request on Github
Attachment #8389701 - Flags: review?(kgrandon)
(In reply to Francesco Lodolo [:flod] from comment #8)
> Peter, can you explain me what the problem is for zh-TW? I'm looking also at
> the zh-CN but I can't see anything wrong.
> 
> This bug is about line-height being to small for locales where "All day"
> spans on two lines (see highlighted areas in the first screenshot).

Please refer to bli's attachment AllDayEvent_zh-CN. The line-height is also too small for Chinese so some 2 or 4 pixels were truncated for term "All day" (全天). 
The top inverted V-shape cap of word "All" ("全") should touch at top center of the character, and the top horizontal stroke of word "day" ("天") is thinner than the second stroke.

In this case, both Trad and Simp Chinese use same characters for translation so this bug affects both locales.

Still reproducible in today's Gaia 1.3 (build f385eb84)
Assignee: nobody → francesco.lodolo
Status: NEW → ASSIGNED
Comment on attachment 8389701 [details] [review]
Pull request on Github

R+, but please change the units to rem first.
Attachment #8389701 - Flags: review?(kgrandon) → review+
Thanks Kevin, I'll update the patch and wait for Travis to re-run.

@Peter
Thanks for the explanation. I tried zh-TW on my patched phone and with line-height: 1.2rem I see the difference with the previous screenshot.
Keywords: checkin-needed
Landed: https://github.com/mozilla-b2g/gaia/commit/6a85bb50b9e3f2f418051e64b7669a1f9a9efe81
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Verified on Keon, master git commit 3977de3c 2014-03-24
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.