Closed Bug 929757 Opened 7 years ago Closed 7 years ago

Animating transform incorrectly affects height of containing element

Categories

(Core :: Layout, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 928607

People

(Reporter: jugglinmike, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Given three nested elements A, B, and C, where C is taller than B:

    +-----------+
    |A          |
    | +-------+ |
    | |B      | |
    | | +---+ | |
    | | | C | | |
    | | |   | | |
    | +-------+ |
    |   |   |   |
    |   +---+   |
    +-----------+

If B declares `overflow-y: hidden;` and C's `transform` attribute is modified, then A expands to contain C (even though B continues to "mask" C correctly).

I've attached a reduced test case that demonstrates this behavior in Firefox Nightly 27.0a1 (2013-10-22).

This was first discovered in Gaia--see bug 907177. As mentioned there, we believe this regression was introduced with the following commit: http://hg.mozilla.org/mozilla-central/rev/45d9e6cd3473
Summary: Animating transform causes incorrectly affects height of containing element → Animating transform incorrectly affects height of containing element
@roc could you comment?
Flags: needinfo?(robert)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928607
You need to log in before you can comment on or make changes to this bug.