Closed Bug 929862 Opened 6 years ago Closed 6 years ago

Defect - OSK quickly appearing/disappearing when tapping on Facebook chat boxes

Categories

(Firefox for Metro Graveyard :: Input, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 950832

People

(Reporter: kjozwiak, Unassigned)

Details

Attachments

(1 file)

When tapping in the textbox on a Facebook chat window at the bottom of the screen, the OSK won't always appear and then when you tap anywhere else on the screen it will quickly appear/disappear.

- Attached a short video of the issue (notice the OSK quickly appearing/disappearing)

Steps to reproduce the issue: (doesn't occur 100% of the time, need to try it a few times and you'll definitely see the issue)

1) Open Firefox Metro
2) Go to facebook.com
3) Login and tap on any name on the right hand side to initialize a chat window at the bottom of the screen
4) Tap inside the textbox of the chat window, sometimes you won't get the OSK to appear. When that happens, tap somewhere else on the website and you should notice the OSK will quickly appear and then disappear

Current Behaviour:

- OSK not always appearing when tapping on the Facebook Chat window at the bottom of the screen. When you tap anywhere else after that, the OSK will appear and then disappear

Expected Behaviour:

- OSK should appear every single time when tapping on the Facebook Chat textbox and then disappear when either dismissing the chat box or tapping anywhere else on the screen
Whiteboard: feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 → [triage] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0
Whiteboard: [triage] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 → [release28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0
after more than half an hour of trying, I can't repro this on either my surface pro or vaio.

I've asked sdwilsh to take a swing at it from the fb side.
Ally, I will take another look tonight and see if its still happening using the lenovo X1 carbon. Perhaps it was fixed somewhere down the line.
I can still reproduce the problem but instead of the OSK appearing/disappearing quickly, it just flashes. You can see the OSK appear/disappear in an instant making it seem for of a "flash". In the original video attached, you can at least see the OSK quickly appear/disappear.
Whiteboard: [release28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 → [beta28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0
Blocks: 950249
Assignee: nobody → spohl.mozilla.bugs
Whiteboard: [beta28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=0 → [beta28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=3
Blocks: metrov1it21
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
Priority: -- → P2
QA Contact: jbecerra
I'm not able to reproduce this with bug 944215 applied. Although in bug 950249 I'm unable to bring up the osk at all.
Depends on: 944215
Depends on: 950832
Hmm, I'm still able to reproduce this even with bug 944215 applied. I found these steps to reproduce the issue reliably:

1. Tap in chat box for cursor to appear.
2. Tap again for osk to appear. (This is probably a bug too, since the osk should have appeared in step 1)
3. Dismiss the osk by tapping somewhere else on the page.
4. Tap in chat box again for cursor to appear.
5. Tap somewhere else on the page.

Result:
OSK shows and dismisses quickly.

It seems necessary to show the osk at least once for this bug to start occurring. Jim, are you able to reproduce with these steps?
Flags: needinfo?(jmathies)
(In reply to Stephen Pohl [:spohl] from comment #5)
> Hmm, I'm still able to reproduce this even with bug 944215 applied. I found
> these steps to reproduce the issue reliably:
> 
> 1. Tap in chat box for cursor to appear.
> 2. Tap again for osk to appear. (This is probably a bug too, since the osk
> should have appeared in step 1)
> 3. Dismiss the osk by tapping somewhere else on the page.
> 4. Tap in chat box again for cursor to appear.
> 5. Tap somewhere else on the page.
> 
> Result:
> OSK shows and dismisses quickly.
> 
> It seems necessary to show the osk at least once for this bug to start
> occurring. Jim, are you able to reproduce with these steps?

Yeah this is all bug 950832. I think in the end this will end up a dupe.
Flags: needinfo?(jmathies)
No longer blocks: 950249
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
No longer depends on: 944215, 950832
Resolution: --- → DUPLICATE
Whiteboard: [beta28] feature=defect c=Other_charms_and_integration u=metro_firefox_user p=3
Duplicate of bug: 950832
No longer blocks: 855297, metrov1it21, 906048
After testing a preliminary patch for bug 950832, I agree that this will most likely be fixed by the patch there. I'll unassign myself from this patch for now to look at other remaining beta blockers.
Assignee: spohl.mozilla.bugs → nobody
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950832
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.