Closed Bug 930509 Opened 8 years ago Closed 7 years ago

Test failure 'Window has been found.' in testCloseDownloadManager.js and testOpenDownloadManager.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P1)

defect

Tracking

(firefox26 disabled, firefox27 disabled)

RESOLVED FIXED
Tracking Status
firefox26 --- disabled
firefox27 --- disabled

People

(Reporter: andrei, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [mozmill-test-failure][Blocked by bug 1083655])

Attachments

(1 file)

Module:    testCloseDownloadManager
Test:      /testDownloading/testCloseDownloadManager.js    
Failure:   Window has been found.
Branches:  default
Platforms: All

Seem a genuine regression. Fails on all platforms, all the time.
We should skip it ASAP.
Summary: Test failure 'Window has been found.' in /testDownloading/testCloseDownloadManager.js → Test failure 'Window has been found.' in testCloseDownloadManager.js and testOpenDownloadManager.js
Attached patch skip.patchSplinter Review
Skip patch
Attachment #821674 - Flags: review?(andreea.matei)
Comment on attachment 821674 [details] [diff] [review]
skip.patch

Review of attachment 821674 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, the commit message needs to be changed though.
Attachment #821674 - Flags: review?(andreea.matei) → review+
Disabled: http://hg.mozilla.org/qa/mozmill-tests/rev/81db85e5ad51 (default)

Damn, I didn't update the commit message to include disabled :(
Regressor might be bug 928349

Mario, please check with tinderbox builds to be sure.
I can confirm that that bug is in the pushlog between the last good and first bad tinderbox builds:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d9f5b1eb84e8&tochange=4ceaf2926e5b

Last Good:
ID- 1382557179
Changeset- d9f5b1eb84e8
URL - ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux/1382557179/

First Bad:
ID- 1382590208
Changeset- 4ceaf2926e5b
URL- ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux/1382590208/

There aren't any other tinderbox builds in between those two.
Thanks Mario for the regression range.
We do have bug 928349 in that merge from fx.
Blocks: 928349
The affected 2 tests are obsolete:
> testCloseDownloadManager.js
> testOpenDownloadManager.js

We should convert them to test the new Library Window.

I've touched on that in bug 908649 where we need the Library window.
I'll make sure sure handle the Library window there. After that we'll be able to refactor these 2 tests to check the new Library window.
Depends on: 908649
The feature has been backported to Firefox 26.0. So I went ahead and backported this patch:
http://hg.mozilla.org/qa/mozmill-tests/rev/0aa97dc0b0ba

Andrei, next time please use a proper commit message. The one used for default doesn't really say much.
We split the dependency bug in 2, so this tests will be completely replaced with new Places Organizer open/close tests in bug 996530 .
Depends on: 996530
No longer depends on: 908649
Assignee: nobody → daniel.gherasim
Status: NEW → ASSIGNED
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][Blocked by bug 996530]
This test was skipped in functional testing today for Firefox 31.0 RC: http://mozmill-release.blargon7.com/#/functional/report/a3b8d1e9bea5a0fc05cd41dbf639a2a4   I'm recording it here because I got a failure email about it on mozmill-ci.
Depends on: 1083655
No longer depends on: 996530
Whiteboard: [mozmill-test-failure][Blocked by bug 996530] → [mozmill-test-failure][Blocked by bug 1083655]
Assignee: danisielm → nobody
Status: ASSIGNED → NEW
This was fixed by Bug 996530.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.