[Dialer][Buri] Backout of Bug 927724 did not fix Dialer issues

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

Attachments

(1 attachment)

Created attachment 822033 [details]
Logcat

Buri, while using the respun build:

Gaia   2feebdb1a2583928f32407d76d798f8654621e2b
SourceStamp 19fd3388c372
BuildID 20131024154023
Version 27.0a1

STR:
1. Launch the dialer on one Buri device and call the other one

Expected: I would receive the call
Actual: Many times the inbound call is not received.

There was a backout in https://bugzilla.mozilla.org/show_bug.cgi?id=927724 but it seems it did not fully address the dialer issues. 

Other issues seen:
*Outbound calls are often missing UI, so you can connect a call but then there is not button hang up.
*Usage app launches with a black screen

Updated

5 years ago
Keywords: regression, smoketest
Checked with Rel Eng, and they confirmed:

"the gaia revision the nightly is pointing at (according to bugzilla) is after the backout" - https://github.com/mozilla-b2g/gaia/commits/master
EJ chen, can you please help ?
Flags: needinfo?(ejchen)
I tested the same build and there are the same problems like what Marcia mentioned. Not sure is there any Gecko change to cause these problems (?) because bug-927724 has been backed out already. Any ideas (?)
Flags: needinfo?(ejchen)
Btw - let's use bug 930555 to track the cost control issue separate from the dialer issue here.
This might be fixed by the backout of bug 924702. Can someone test with a Gecko version that includes this backout?
(In reply to Anthony Ricaud (:rik) from comment #5)
> This might be fixed by the backout of bug 924702. Can someone test with a
> Gecko version that includes this backout?

Confirmed fixed by backout in today's smoketest.
Blocks: 924702
Status: NEW → RESOLVED
blocking-b2g: 1.3? → 1.3+
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.