Closed Bug 931108 Opened 6 years ago Closed 6 years ago

Dotted outline of navbar in customize mode is in the wrong place after bug 895836

Categories

(Firefox :: Toolbars and Customization, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: Gijs, Assigned: MattN)

References

Details

(Keywords: regression, Whiteboard: [Australis:P3][fixed by bug 963576])

Attachments

(1 file)

I suspect that it was genuinely the padding that needed changing, not the margin.
Summary: Outline of customize mode is in the wrong place after bug 895836 → Dotted outline of navbar in customize mode is in the wrong place after bug 895836
Whiteboard: [Australis:P3] → [Australis:P2]
The margin was reduced by 2px, so to put the outline back in the original place I'd have to use offset: -2px, but unfortunately that makes the offset touch the back button. So I went with -1px, which at least makes it no longer touch the navbar's top border.
Attachment #826699 - Flags: review?(mdeboer)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 826699 [details] [diff] [review]
use outline-offset to ensure the nav-bar outline isn't adjacent to the border,

Review of attachment 826699 [details] [diff] [review]:
-----------------------------------------------------------------

As per our discussion on IRC, Gijs also thinks this does not fix the issue and needs more time to investigate.

::: browser/themes/shared/customizableui/customizeMode.inc.css
@@ -15,5 @@
>    transition-timing-function: linear;
>  }
>  
>  #nav-bar[customizing] > #nav-bar-customization-target {
> -  margin: 1px 3px;

this re-introduces bug 895836.
Attachment #826699 - Flags: review?(mdeboer) → review-
I looked at this some more, and I think we should probably fix bug 893661 first, otherwise the outcome here will just regress again. Unassigning for now.
Assignee: gijskruitbosch+bugs → nobody
Depends on: 893661
Whiteboard: [Australis:P2] → [Australis:P3]
Blocks: 879981
Status: ASSIGNED → NEW
I don't see the outline at all in the nav-bar on OS X anymore.
Matt, I think this looked OK after bug 963576 was done. If you agree, can you close as FIXED and set the right target milestone, assignee, and set the right tracking flags for 29 and 30? Thanks!
Flags: needinfo?(MattN+bmo)
Yeah, I set outline-offset in bug 963576 to address this (or at least from what I can tell without a screenshot in this bug). I forgot this bug existed.
Assignee: nobody → MattN+bmo
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → FIXED
Whiteboard: [Australis:P3] → [Australis:P3][fixed by bug 963576]
Target Milestone: --- → Firefox 30
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.