Closed Bug 931415 Opened 6 years ago Closed 6 years ago

'Action menus' don't seem to work in Gaia on Firefox OS 1.2

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 931351

People

(Reporter: znmeb, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130917102914

Steps to reproduce:

1. Bought a ZTE Open
2. Followed the configuration and build instructions for the 1.2 branch. Logs attached
3. Flashed the ZTE Open


Actual results:

Most everything seems to be working. However:

1. In the introductory setup dialog, the Time Zone setting didn't work. If I press the time zone setting button, I get a blank 'Action Menu' with just 'Select' at the top and 'OK' at the bottom. There aren't any time zone options listed.
2. In the 'Usage' app, there's a dialog to set the starting date on a monthly usage tracking. Pressing this gives the same thing as 1 - 'Select' at the top, 'OK' at the bottom, and nothing in between.
3. In the 'Display' menu in 'Settings', the 'Screen Timeout' gives the same thing.


Expected results:

For 1, a list of time zones. For 2, a list of starting dates from 1 to 31. For 3, a list of screen timeout values.
Severity: normal → major
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
I now have a working build. I don't know if this is a source change in the B2G tree or a change in my build process that fixed it, so I'm attaching the logs of the working build.

So it looks like the worst case is that there's an error somewhere in the documentation for how to build from source. I'm going to call this 'unable to reproduce' for now.
Host is Fedora 19 - build scripts are on Github at https://github.com/znmeb/firefox-os-build
P.S.: I ran an emulator build in the source tree before running this build. I doubt if that's why it worked this time, though.
This sounds like bug 931351.
Yup ... marking as duplicate!
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 931351
You need to log in before you can comment on or make changes to this bug.