Dropdown/select lists empty/broken (e.g. timezone region and city pickers in ftu and settings, language picker in settings)

VERIFIED FIXED

Status

Firefox OS
Gaia::System
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

Geeksphone Keon with Gaia 1.2.0.0-prerelease 20131025225454 (Gecko 3c4573e, Gaia 9e23163)

The dropdown lists to select the timezone region and city are empty when tapping on them (in first time run and settings), the language picker in the settings app is also empty, so this seems to be a general problem.
This still works as expected in 20131024 (Gecko ab2e967, Gaia b67568c).

From the logcat:

E/GeckoConsole(  557): Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.

I/Gecko   (  557): ###################################### forms.js loaded

I/Gecko   (  557): ############################### browserElementPanning.js loaded

I/Gecko   (  557): ######################## BrowserElementChildPreload.js loaded

Comment 2

4 years ago
Buri and Wasabi has the problem as well.
Gaia:     04ee9e4430b25ba2c38752d3897f0ee5e2a6ab80
Gecko:    http://hg.mozilla.org/releases/mozilla-aurora/rev/52f24889dccc
BuildID   20131027004003
Version   26.0a2

Updated

4 years ago
Keywords: regressionwindow-wanted

Comment 3

4 years ago
Wasabi 1025031555 build has no such bug, but later one has.
Gaia:     b67568c07ccde602b43115efade3170234ac95a5
Gecko:    ab2e9673cd90af3b7e8d18472e0373bdd6743daf
BuildID   20131025031555
Version   26.0a2

Updated

4 years ago
Duplicate of this bug: 931754

Updated

4 years ago
QA Contact: sparsons

Updated

4 years ago
Duplicate of this bug: 931855

Comment 6

4 years ago
Smoketest blocker.  All dropdowns are missing and unable to test anything like switching languages, display screentimeout, etc..
Component: Gaia → Gaia::System
Keywords: smoketest

Comment 7

4 years ago
This issue started to occur on the Buri 1.2 Aurora Build ID:20131026004003

Gaia   de70f4d9b7a8dd3ba2565184735094eaa2bd3d18
SourceStamp 780de7966fc0
BuildID 20131026004003
Version 26.0a2


Last Working Buri 1.2 Aurora Build ID:20131025004000

Gaia   606517ceafe0950c2b89822d5f13353743334f2c
SourceStamp 5eabd267ef04
BuildID 20131025004000
Version 26.0a2

Updated

4 years ago
Keywords: regressionwindow-wanted
Duplicate of this bug: 931708
bug 924893 caused this.
Blocks: 924893
This is fixed by the backout of bug 924893.
Status: NEW → RESOLVED
blocking-b2g: koi? → koi+
Last Resolved: 4 years ago
Resolution: --- → FIXED
The Gaia part of bug 924893 was backed out from v1.2 and the Gecko part never landed there. Calling this fixed.
status-b2g-v1.2: --- → fixed

Updated

4 years ago
Duplicate of this bug: 931415
Fix verified on Buri 1.2 commercial RIL.  The Region and City dropdown lists are now populated.

Build ID: 20131107004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/26f1e160e696
Gaia: 590eb598aacf1e2136b2b6aca5c3124557a365ca
Platform Version: 26.0
RIL Version: 01.01.00.019.281
Status: RESOLVED → VERIFIED
status-b2g-v1.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.