Closed Bug 931687 Opened 6 years ago Closed 3 years ago

Add -Gw option when using profiledbuild by VS2013

Categories

(Firefox Build System :: General, defect)

x86
Windows 8.1
defect
Not set

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla28
Tracking Status
firefox52 --- fixed

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

Attachments

(1 file, 2 obsolete files)

Sse http://blogs.msdn.com/b/vcblog/archive/2013/09/11/introducing-gw-compiler-switch.aspx.  We can get a few size benefit.


Before
======
 12829696  13/10/24 11:54   firefox/mozjs.dll
  3542528  13/10/24 11:25   firefox/gkmedias.dll
 22132224  13/10/24 12:10   firefox/xul.dll

After
=====
 12796416  13/10/23 19:41   firefox/mozjs.dll
  3497472  13/10/23 19:07   firefox/gkmedias.dll
 22121472  13/10/23 19:59   firefox/xul.dll
Attached patch fix (obsolete) — Splinter Review
Attachment #823242 - Flags: review?(ted)
Comment on attachment 823242 [details] [diff] [review]
fix

Review of attachment 823242 [details] [diff] [review]:
-----------------------------------------------------------------

As I read it, this is not a LTCG/PGO specific flag. Just use it for all builds by putting it in CFLAGS/CXXFLAGS.
Attachment #823242 - Flags: review?(ted) → review-
Attached patch -Gw option (obsolete) — Splinter Review
Assignee: nobody → m_kato
Attachment #823242 - Attachment is obsolete: true
Attachment #824423 - Flags: review?(mh+mozilla)
Attachment #824423 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/040e85d18eab
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 1018402
Backed out per bug 1018402 comment 45: https://hg.mozilla.org/integration/mozilla-inbound/rev/382fcf193cba

I left the corresponding NSS and NSPR changes intact because they are not causing any harm.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1126662
Is this something we should look at again now that we're on MSVC 2013?
Flags: needinfo?(mh+mozilla)
Per bug 1018402 comment 50, I think we can re-land this!
Attached patch -Gw optionSplinter Review
This is essentially the same patch from comment 3, transplanted to the "old-configure" system. But it's been a long time so re-requesting review.
Attachment #824423 - Attachment is obsolete: true
Attachment #8798239 - Flags: review?(mh+mozilla)
libxul has put on some weight since the days of comment 0, but there's still a size win:

Before:
10/04/2016  11:36 AM        54,690,816 xul.dll
After:
10/04/2016  12:11 PM        53,851,136 xul.dll
Attachment #8798239 - Flags: review?(mh+mozilla) → review+
Pushed by dmajor@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/af534f12f8fe
Use the -Gw flag on Windows builds for better linker optimizations. r=glandium
https://hg.mozilla.org/mozilla-central/rev/af534f12f8fe
Status: REOPENED → RESOLVED
Closed: 6 years ago3 years ago
Resolution: --- → FIXED
Depends on: 1311211
Flags: needinfo?(mh+mozilla)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.