Closed Bug 931785 Opened 7 years ago Closed 5 years ago

sport24.gr doesn't redirect to mobile site on Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: alefteris, Unassigned, Mentored)

References

()

Details

(Whiteboard: [country-gr][clientsniff][sitewait] )

Attachments

(1 file)

Site: http://www.sport24.gr
sport24.gr doesn't redirect to mobile site on Firefox OS

:: Steps To Reproduce

1. Open Firefox OS browser
2. Type sport24.gr in Firefox OS browser

:: Expected Result

Get redirected to http://m.sport24.gr. When typing the Web site address on Firefox for Android or iOS Safari we get redirected to the mobile site.

:: Actual Result

We receive the desktop site of http://www.sport24.gr

:: Additional Information

Software Version: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
Device Information: Keon
Whiteboard: [country-gr]
In http://24media.gr/en/article1908010.ece/BINARY/original/js-utils.js,

ui.mobile.detect.Frame.prototype.check=function(){if(this.isMobile(navigator.userAgent)){if(Cookie.get("edition_preference")&&Cookie.get("edition_preference")=="desktop"){this.display.call(this)
}else{return"http://"+this.domain+"/redirect?search="+encodeURIComponent(window.location.href)
}}return null
};
...
ui.mobile.detect.Frame.prototype.isMobile=function(b){var a={Android:function(){return b.match(/Android/i)?true:false
},BlackBerry:function(){return b.match(/BlackBerry/i)?true:false
},iOS:function(){if(b.match(/iPad/i)){return false
}return b.match(/iPhone|iPod/i)?true:false
},Windows:function(){return b.match(/IEMobile/i)?true:false
}};
return(a.Android()||a.BlackBerry()||a.iOS()||a.Windows())
};

So we need them to add perhaps a generic "mobile" inside their isMobile. We probably don't want to add a UA override here as android because then we'll get a useless Google Play ad:


<script src="/static/smartbanner/jquery.smartbanner.js"></script>
		<script type="text/javascript">
			$.smartbanner({
			title: null, // What the title of the app should be in the banner (defaults to <title>)
			author: null, // What the author of the app should be in the banner (defaults to <meta name="author"> or hostname)
			price: 'FREE', // Price of the app
			appStoreLanguage: 'us', // Language code for App Store
			inAppStore: 'On the App Store', // Text of price for iOS
			inGooglePlay: 'ΚΑΤΕΒΑΣΕ ΤΗΝ ΕΦΑΡΜΟΓΗ', // Text of price for Android
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr] → [country-gr][clientsniff][contactready]
Here's a drop-in replacement they can use: https://gist.github.com/anonymous/7199832
See Also: → 931808
Depends on: 931899
Whiteboard: [country-gr][clientsniff][contactready] → [country-gr][clientsniff][sitewait]
Whiteboard: [country-gr][clientsniff][sitewait] → [country-gr][clientsniff][sitewait] [mentor=kdubost]
Mentor: kdubost
Whiteboard: [country-gr][clientsniff][sitewait] [mentor=kdubost] → [country-gr][clientsniff][sitewait]
Invalid sport24 seems to not have anymore a mobile site.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.