i.pathfinder.gr doesn't render properly on Firefox for Android

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: alefteris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-gr][webkitcss][sitewait], URL)

(Reporter)

Description

5 years ago
Site: http://i.pathfinder.gr
i.pathfinder.gr doesn't render properly on Firefox for Android

:: Steps To Reproduce

1. Open Firefox for Android app
2. Type i.pathfinder.gr in Firefox for Android address bar

:: Expected Result

The site should render the same as it does for iOS Safari.

:: Actual Result

When viewing with Firefox for Android there are background gradients missing and rounder corners not working.

:: Additional Information

Firefox for Android Beta
Software Version: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0
Device Information: ZTE Blade
(Reporter)

Updated

5 years ago
Blocks: 931901
Lots of -webkit- only CSS without friendly fallbacks in http://i.pathfinder.gr/css/css.css.

Also in http://i.pathfinder.gr/js/js.js a few problems: only adding event listeners for 'webkitTransitionEnd' events, only adding 'webkitTransform' style properties, relying on window.orientation.

If you unpack the core.js (https://gist.github.com/anonymous/7205559), there is an author listed: author: "georgep@phaistosnetworks.gr", so that might be a good person to reach out to. The code looks like it was updated recently, so it's at least maintained: // Core.Packed: 22/10/2013 17:22:24. Lots of UA sniffing in core.js, but doesn't look overly webkit specific.

Given the "i" subdomain, I'm guess they designed this site specifically for iDevices. But just a little bit of work and it should work across browsers.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-gr][webkitcss][contactready]
(Reporter)

Comment 2

5 years ago
The mobile site also seems to lack a favicon, it only has defined an apple touch icon. Even though android generally supports apple touch icons, the way it's implemented here is not working when bookmarking to home screen.
(Reporter)

Updated

5 years ago
Whiteboard: [country-gr][webkitcss][contactready] → [country-gr][webkitcss][sitewait]
(Reporter)

Comment 3

5 years ago
I send a message using the contact form at http://contact.pathfinder.gr
(Reporter)

Updated

5 years ago
See Also: → bug 931901
(Reporter)

Comment 4

5 years ago
Got a reply back that said that they where targeting just iDevices when they implemented the site. They said that they made some fixes and it does look better now, but still has some issues. They also said that the site is being redesigned and the next version will support all mobile browsers.

Not sure if I should ask them to fix the redirection issue.
I see backgrounds, no rounded corners - the real problem I see is that if I go to "News", the top toolbar disappears after loading in FxOS while it stays below the logo area in Android stock browser. Likely because they rely on window.orientation usage (this toolbar goes away in landscape mode on Android).
Depends on: 920734
I think this is resolved now - Thanos, please check and reopen if necessary :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.