[B2G] Date and Time Pickers' carousels are not continuous

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
RESOLVED WONTFIX
5 years ago
5 months ago

People

(Reporter: Matthew Vaughan, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: permafail)

(Reporter)

Description

5 years ago
Description:
The Date and Time Pickers within the FTE and Settings app are not on a continuous carousel. Instead, the user reaches the end of the list and will have to scroll through the entire list if they need to select an option on the opposite end. (ex. If user is at day 1 and wants day 30, they need to scroll down through the list instead of just up to go right from day 1 to 30). This fails test case 2379 in BuriRun3.

Repro Steps:
1) Update Buri to v1.2 comRIL BuildID: 20131025004000
2) Launch the Settings app
3) Select Date & Time
4) If needed, disable "Set automatically"
5) Tap on Date
6) Scroll through the picker carousel, attempting to go right from the end to the beginning of the list
7) Back out to the Date & Time menu
8) Tap on Time
9) Scroll through the picker carousel, attempting to go right from the end to the beginning of the list

Actual:
The Date and Time Pickers' carousel is not continuous; user has to scroll from one end to another to choose options from opposite ends of the carousel.

Expected:
The Date and Time Pickers' carousel is continuous; there is no end to the pickers' scrolling.

Environmental Variables:
Device: Buri v1.2 comRIL
BuildID: 20131025004000
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Gecko: 5eabd267ef04
Version: 26.0a2
RIL Version: 01.02.00.019.082

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2379/
(Reporter)

Comment 1

5 years ago
Further investigation reveals that these pickers are located in multiple areas/apps. Assuming that the pickers are not all separate entities in each app, I have edited the bug title to better reflect a global issue.

Other apps that these pickers are observed in are Calendar and Clock.
Component: Gaia::Settings → Gaia
Summary: [B2G][Settings][FTE] Date and Time Pickers' carousel is not continuous → [B2G] Date and Time Pickers' carousels are not continuous
Does this reproduce on 1.1?
Component: Gaia → Gaia::System
Keywords: qawanted

Comment 3

5 years ago
This issue reproduces on Leo 1.1 Build ID: 20131029041202

Gaia   39b0203fa9809052c8c4d4332fef03bbaf0426fc
SourceStamp 41c15ddb7216
BuildID 20131029041202
Version 18.0
Keywords: qawanted

Updated

5 years ago
QA Contact: sparsons

Updated

5 years ago
status-b2g18: --- → affected
Duplicate of this bug: 808642

Updated

5 years ago
status-b2g-v1.3: --- → affected
Whiteboard: burirun3 → burirun3, burirun1.3-2
status-b2g-v1.4: --- → affected
Whiteboard: burirun3, burirun1.3-2 → burirun3, burirun1.3-2, burirun1.4-1
Whiteboard: burirun3, burirun1.3-2, burirun1.4-1 → permafail

Updated

4 years ago
Duplicate of this bug: 980716
status-b2g-v1.3T: --- → affected
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → affected
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
status-b2g-v2.1: --- → affected
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)

Comment 6

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.