Closed Bug 932235 Opened 6 years ago Closed 6 years ago

new email link icon

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(firefox29+ fixed)

RESOLVED FIXED
Firefox 29
Tracking Status
firefox29 + fixed

People

(Reporter: mixedpuppy, Assigned: shorlander)

References

(Blocks 1 open bug)

Details

(Keywords: icon, Whiteboard: [Australis:P3])

Attachments

(6 files)

We need a new email link icon that is different than the share icon, since both may be visible.
Actually, how bug 879982 is currently implemented, they can't be visible at the same time. Might still make sense to have a separate icon of course.
(In reply to Felix H. Dahlke from comment #1)
> Actually, how bug 879982 is currently implemented, they can't be visible at
> the same time. Might still make sense to have a separate icon of course.

Yeah, I just commented in there.  Sorry to run you in circles, but right now it doesn't make sense to conflate share and email until share also handles the default case that is being added in bug 879982.  So it should be possible for both buttons to be enabled.
Note that current implementation does not only change icon direction but also text in overflow mode. When the new icon ships it mus be ensured that the text is right again in overflow.
OS: Mac OS X → All
Hardware: x86 → All
I guess some kind of envelop icon would be nice. Might make a concept icon.
I know some kind of mail icon would be preferred, but this icon is similar to a compose mail icon. Posting a black icon after this one.
Attachment #8347750 - Flags: ui-review?(zfang)
Attachment #8347750 - Flags: ui-review?(shorlander)
This is not really Firefoxy looking, but it's still useful right ?
Attachment #8347752 - Flags: ui-review?(zfang)
Attachment #8347752 - Flags: ui-review?(shorlander)
This
Attachment #8347754 - Flags: ui-review?(zfang)
Attachment #8347754 - Flags: ui-review?(shorlander)
Comment on attachment 8347754 [details]
Envelope icon (Windows 8)

Sorry, end of the description :
This is an envelope style icon. It's made for Windows 8.
If you need a black glyph, just ask.
Flags: needinfo?(shorlander)
Attachment #8347754 - Flags: ui-review?(zfang)
Attachment #8347754 - Flags: ui-review?(shorlander)
Attachment #8347752 - Flags: ui-review?(zfang)
Attachment #8347752 - Flags: ui-review?(shorlander)
Attachment #8347750 - Flags: ui-review?(zfang)
Attachment #8347750 - Flags: ui-review?(shorlander)
Duplicate of this bug: 957615
Duplicate of this bug: 958422
I think Mike Maslaney is in charge of the icons now.
Flags: needinfo?(mmaslaney)
Blocks: 958645
Duplicate of this bug: 963580
Duplicate of this bug: 963580
Attached file Email_Icon.zip
Email icon attached to the global menuPanel and toolbars sprite sheet.
Flags: needinfo?(mmaslaney)
Duplicate of this bug: 965787
Remove transforms to flipped Shareplane. Adds new email icon.
Attachment #8368345 - Flags: review?(jaws)
Needs [Australis] in the commit message, but this can be checked in.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/df246336a9ab
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Whiteboard: [Australis:P3] → [Australis:P3][good first verify]
This icon disappears on OS X retina when clicked.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [Australis:P3][good first verify] → [Australis:P3]
I apologize for the weirdest diff I've ever seen. I only touched the email link icon rules, but instead of moving those it's moved a bunch of other stuff around it...
Attachment #8369189 - Flags: review?(jaws)
Comment on attachment 8369189 [details] [diff] [review]
Australis' email link icon disappears,

Review of attachment 8369189 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, that is a weird diff. It looks like you just moved the rules so that they would be in sprite-sheet order.
Attachment #8369189 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] from comment #23)
> Comment on attachment 8369189 [details] [diff] [review]
> Australis' email link icon disappears,
> 
> Review of attachment 8369189 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Yes, that is a weird diff. It looks like you just moved the rules so that
> they would be in sprite-sheet order.

Aye. And updated the rect()s but yeah. No idea why diff did something that weird. Diff -w wasn't any better.

Anyway, landed: remote:   https://hg.mozilla.org/integration/fx-team/rev/9d4c8dac03fa
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/9d4c8dac03fa
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.